Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX - In-game menu lag
#1
Hello, I'm new to the forum. I've read the rules, but feel free to tell me if I ask anything forbidden that I could've missed.

I've recently started to play FFX International on my computer using PCSX 0.9.6, but as I got to Thunder Plains battle menus would sometime not appear resulting in me needing to reset the emulator. I know you're all aware of this bug, I read about it on these very forums.

BUT, in an attempt to save myself some time (Knowing the Home bug would arrive eventually) I decided to download the beta since it was said it might fix both bugs. Everything went fine, the game runs smoothly and as far as I have tested the elemental/dino/floating-eye combo didn't kill my game. However, my in-game menu lags awfully. Whenever I switch to a menu with alot of options (say like the item or character list), the music and cursor slows drastically. If I'm in a menu with a few option (say the Aeon list, cause I actually only have access to 3), it's fine and runs at normal speed.

I'd like to know if there's something I have set wrong, or if it's a beta-only bug, etc.

My comp spec:
- Intel Core i7 920
- 2667 MHZ
- Radeon 4890

Plug-Ins:
- Graphic: GSdx 1650 0.1.15 SSE41
- DVD: Gigaherz CDVD pluggin 0.7.0
- Sound: SPU2-X 1.1.0

Thanks for your time.
Reply

Sponsored links

#2
Try to untick "Allow 8-bit textures" in GSdx. What's your settings with the new beta?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
It worked perfectly. Thank you very much. And here I was thinking it would be much more complicated. =P
Reply
#4
the option "allow 8-bit textures" is meant to speed up gpu limited games, which ffx certainly isn't Wink

enable it if the cpu usage shown in the title bar of pcsx2 hits 99%, might net you some extra fps then.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#5
Yeah this shouldn't be pre-enabled to begin with, more users getting slowdowns because of it rather than speedups (which makes sense)
It also needs GPUs with lots of VRAM (512mb+) to work best
[Image: newsig.jpg]
Reply
#6
It isn't on by default, only helps a few games with most gfx cards.
Reply
#7
I think I made it on by default.
I know about the slowdown in that menu in ffx (130fps here, instead of 600 or so), but the majority
of games all got faster with it enabled.
I guess you'd need a pretty weak gpu to get such a slowdown anyway (onboard class).
Reply
#8
(08-27-2009, 06:21 PM)rama Wrote: ...
I guess you'd need a pretty weak gpu to get such a slowdown anyway (onboard class).

nope, my card crashes from 200-300 in the menus down to 30fps, too. or did you want to tell us that even the ati radeon hd 48xx series are in your "weak gpu" category? Wink
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#9
Ok, then the menu does something ATI cards don't like.
It still is only one menu in one game, although I guess it's pretty popular :/
Reply
#10
I just booted up my copy of FFX with an internal resolution of 1024x768 and 8bit textures enabled (GSdx r1650). I got around 93 fps when you are first able to access the menu compared to 270 fps without 8bit textures enabled.

My PC
AMD PhenomII X3 720 @ 3.4GHz
ATI Radeon 4870 1GB version
4GBs of DDR3 RAM

Hope this might help the devs.
Reply




Users browsing this thread: 1 Guest(s)