Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX battle animations run too fast! (PCSX2 newbie)
#1
Hiya. First of all, PCSX2 is shaping up to be a GREAT experience for me. I actually built my computer to run PCSX2, despite not being much of a techie.

I've discovered very few problems running it on my computer. The most persistent one for me is with FFX and FFX-2. It feels like sometimes things are running TOO FAST. It is most noticeable in battles: characters normal attacks are typically of sync. The model will run abnormally fast, swing, and a half second later the hit sound effect will go off. This seems to happen in both FFX and FFX-2. I've tested the games Shadowhearts From the New World and several Super Robot Taisen Alpha games, which do not appear to have the same issue.

Any ideas?

Firstly, no, I don't have turbo mode enabled and the framelimmiter is normal. The out-of-sync-ness only happens some of the time, regardless.

EDIT: Also, the animations run fast constantly and consistently. It's not, for example, some of the time or half the time. Also the frame rate hovers around 59, which I'm lead to believe is normal.

EDIT: It also does it regardless of whether I run it from the disc or an ISO.

EDIT: Also, it's not on the basis of the the sync that I assume the animations are running too fast. It feels like the models move faster than they should, particularly in the FFX's opening fights when Auron and Tidus run from one group of enemies to the next. Also, Wakka's attack produces a graphical glitch I'm assuming is related: When Wakka throws his blitzball there's a sort of stutter in his animation before he moves to catch the ball which isn't present when played on a console. If you think recording a battle with GSDX's recording system would clear this up I'm happy to, though I'm not certain how to use it...

Settings and specs and other info: (Will add more at request)

Version:
PCSX2 v 0.9.8

Hardware:
4GB ram,
http://www.newegg.com/Product/Product.as...6820231193
i5-2500k chip,
http://www.newegg.com/Product/Product.as...6819115072
Radeon 6850 graphics card,
http://www.newegg.com/Product/Product.as...6814102908
Motherboard:
http://www.newegg.com/Product/Product.as...6813128487
Windows 7

Plugins:
GSdx-sse4-r4600
lilypad-r4600
SPU2-x-r-4600
cdvdgigaherz

Settings:
No speedhacks
Default Emulation settings

I've tested these settings for GSDX and the problem remains identical on each:
D11 Software / Threads 2
D11 Hardware / 2048 X 2048
D11 Hardware / Native
Reply

Sponsored links

#2
thats not running too fast.
its the audio being buffered to long due to time stretching.
Reply
#3
(06-08-2011, 08:13 AM)Squall Leonhart Wrote: thats not running too fast.
its the audio being buffered to long due to time stretching.

You think so? It certainly SEEMS like the models are moving faster than they should in battle, but I'm certainly open to that option. Any idea how to fix it?
Reply
#4
In going with Squall's advice, there is really only one other option. Just look in the sound settings, and make the switch from time stretch, to async mix.
Reply
#5
Hm, I'll try playing with that changed... though after testing it I can't tell if it's syncing better or if it's just my imagination. I'll get back to you.
Reply
#6
moving from interlaced to non interlaced displays can appear faster, its a trick of the eyes.
Reply
#7
(06-08-2011, 09:02 AM)Squall Leonhart Wrote: moving from interlaced to non interlaced displays can appear faster, its a trick of the eyes.

Ah, actually I was wondering about that. Currently it says "interlaced (field)". Where are the controls for that setting anyway?

EDIT: Oh, wait, do you mean switching between none -> weave -> Bob - > Blend? I know how to control that and I don't change that setting in FFX (though in FFX-2 I need it to keep the screen from shaking).
Reply
#8
You can also press F5 during gameplay to cycle through the interlacing options.

You didn't read The Configuration Guide, huh? Tongue

Please, do read the stickies. Smile
Reply
#9
(06-08-2011, 10:02 AM)Rezard Wrote: You can also press F5 during gameplay to cycle through the interlacing options.

You didn't read The Configuration Guide, huh? Tongue

Please, do read the stickies. Smile

*blink blink*

I did know that, actually. And I did read the configuration guide, which is where I learned to use that to stop the screen from shaking. Did you see my last edit? Laugh

Anyway, pardon me for poorly phrasing the question. What I was asking about was the significance of the phrase "Interlaced (field)" at the top of the PCSX2 GUI. I'm lead to believe it's a setting I haven't yet figured out how to affect, since it's right next to the Interlaced option setting (aka the aforementioned F5 options), however it appears to be unrelated as it doesn't change when I press F5. I can't find anything in the configuration guide that mentions it, and none of the options in the PCSX2 appear to be related to it. So... why is it there? What setting does it relate to?

This is admitely unrelated to my inquiry about FFX, I just got curious when you brought up Interlacing because I thought you were talking about it... and not the F5 option thing.

EDIT: It's sort of like a light on the dashboard of your car that you've never seen come on, you can't recognize what it does and you don't know how to affect it and you can't help but wonder what the HECK it's there for.
Reply




Users browsing this thread: 1 Guest(s)