Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX characters flickering, help please?
#1
Wink 
Hey! Smile

I've been playing FFX recently on my new rig, as I never played it much before, only on my cousin's borrowed PS2 for a day. So far it's been great, it's amazing the emulation quality of the PS2 hardware thanks to you guys Laugh. However, I've been experiencing some characters flickering. It usually happens when there are around more than 4-5 characters onscreen (excluding battles), camera changes and movement in some areas, also when some alpha effects start showing up (screen/enemy/object fading, etc).

My specs:
ECS P45T-A Black Edition
Core2Duo E7500 @ 2.93Ghz (stock)
GeForce 9800GTX+ 512Mb GDDR3
1GB RAM 667Mhz
Windows 7 RC1 x86
PS2 Controller (Laugh)

PCSX2 config:
[Image: config.PNG]
[Image: cpu.PNG]
[Image: speed.PNG]
[Image: adv.PNG]

Plugins config:

GSDX (latest, SSE4.1)
[Image: gsdx.PNG]

SPU2-X
[Image: snd.PNG]

Are there any stuff I could try?

Stuff I've tried:
  • Enabling/disabling INTC Sync Hack
  • Enabling/disabling IOP x2 cycle rate
  • Enabling/disabling x1.5 cycle rate
  • Using GSDX software mode instead of hardware (DX10) but it's very slow, and it flickers anyways.

I'm playing with all speed hacks disabled right now, since I read it could lead to flickering, but it still does Sad.

Any help is appreciated! Laugh
..:: Core2Duo E7500 OC @ 3.23 Ghz | 9800GTX+ 512Mb GDDR2 | 2GB DDR2 800 | Win7 x64 ::..
Reply

Sponsored links

#2
Try and download the latest beta from the website (1474). I also recommend you disable frameskip as that can often times cause graphic glitches. If you get some slow down... 1.5x cycle sync as well as some of the other speed hacks should take care of it without any harmful side effects in FFX.

(edit) Also disable 8-bit textures. You should only ever have it on with games where you get 99% CPU usage in the toolbar, and even sometimes then it won't help.
[Image: 2748844.png]
Reply
#3
Hey Koji, thanks for the answer Smile

I just tried the beta with no skipping. I had to enable a few hacks to keep up with 60fps (hopefully, at least until now it's behaving pretty cool) such as x1.5 cycle rate, INTC sync hack, IOP x2 cycle rate and Idle Loop FastFwd.

I'll keep posting if the error comes up again. I've noticed it comes up with VU skipping, but man, PCSX2 stable's non-VU frameskipping was pretty cool, I hope it gets added again, so maybe it would work even better Tongue
..:: Core2Duo E7500 OC @ 3.23 Ghz | 9800GTX+ 512Mb GDDR2 | 2GB DDR2 800 | Win7 x64 ::..
Reply
#4
protip for the future gaming experience, dont summon shiva if you dont want to wait 10 minutes with 1fps for summon sequence to end Tongue
Check my profile for hardware/software and games i played on PCSX2.
Reply
#5
if you get only 1fps during the shiva summoning then you have a serious configuration problem, perhaps your internal resolution is set too high or try an earlier gsdx revision (pre 14xx revs are better for ati users in this game).
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#6
Well, I think this is why I stopped using the beta right on the beginning, sorry I didn't mention it before Tongue. Sometimes, when reaching cutscenes, or changing camera (it doesn't happen on actual gameplay, just cutscenes), I get gibberish like this:

[Image: boohoo.png]

Random colored polygons all over the screen, and after a few seconds of it, it crashes PCSX Sad, so huh, it was good using the beta until that part :/ I tried restarting and playing the whole blitzball game again, with no avail :/

Edit: Is there any windows build for x64? or does the windows download (beta or stable) detects the OS version and acts accordingly?
..:: Core2Duo E7500 OC @ 3.23 Ghz | 9800GTX+ 512Mb GDDR2 | 2GB DDR2 800 | Win7 x64 ::..
Reply
#7
hm, it's kinda weird that you need speed hacks at all, because ffx is rather less demanding for a 3d ps2 game. set your cpu options in pcsx2 to "default" and disable microvu, also try an earlier beta of gsdx.

and no, there are no x64 builds for windows. the team experimented with x64 builds, but they were even slower than the x86 builds, so the idea was scrapped. and the x86 binary runs fine in an x64 windows, without any speed or compatibility issues.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply




Users browsing this thread: 1 Guest(s)