Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX choppy gameplay
#1
First of all, thanks for your support ; )
Second, my specs:

AMD Anthlon Dual Core QL-64 2.10GHz (lap)
3.00GB RAM
Windows Vista 32 bit
Graphics: NVIDIA 8200M G

I am using Pcsx2 0.9.6, currently trying to reach 50-60 fps in FFX, I hope it is possible with my specs.
For the graphics plugin: ZeroGS, worked much better than GSDx for me.
Gigaherz's CD/DVD plugin, with ISO made out of MagicISO, mounted with MagicDisc.
CPU: All defaults
Speed Hacks: x2 Cycle rate ( only thing checkmarked )

I started off with trying to use VU Skip, and the speed gets nicely to 50-60fps, but many of the characters/sprites get choppy and start appearing/disappearing as i walk/stand. Cinematics have no problem at all, and the battle sequences get a bit choppy too.

What I am attempting to do is to keep the speed VU skip does, without getting it choppy.

Right now I got my fps up to 40 without getting it choppy. (Without VU)
If i enable VU, the fps gets to 55-60, but then the characters and other sprites begin disappearing. I read various threads here, but I didnt seem to find anybody with my problem. I do not know if they tried VU either.

Thanks for replies Happy
Reply

Sponsored links

#2
Download and use the latest beta (revision 1888, there are download links in the forum or on the top part of the main download page). It's noticably faster and has a speed hack more or less specifically designed for FFX that works really nicely.

Also, there really isn't a reason why GSDx should be going slower, in fact it should probably be the exact opposite. DirectX10 mode of GSDx should give you a fairly decent speed increase. Again, use the latest GSDx bundled with revision 1888 and see if you get better results.


As a side note, VU skip was removed in the newer betas since it was really buggy. Instead, a new speed hack called Vu Cycle steal was added which is much more stable, but it's best not to use frame skip while you use that option as well.
[Image: 2748844.png]
Reply
#3
(11-20-2009, 03:32 AM)Koji Wrote: Download and use the latest beta (revision 1888, there are download links in the forum or on the top part of the main download page). It's noticably faster and has a speed hack more or less specifically designed for FFX that works really nicely.

Also, there really isn't a reason why GSDx should be going slower, in fact it should probably be the exact opposite. DirectX10 mode of GSDx should give you a fairly decent speed increase. Again, use the latest GSDx bundled with revision 1888 and see if you get better results.


As a side note, VU skip was removed in the newer betas since it was really buggy. Instead, a new speed hack called Vu Cycle steal was added which is much more stable, but it's best not to use frame skip while you use that option as well.

Thanks for reply. Ill post back again with the results :]
Reply
#4
Ok, I just tried again with the updated beta and GSdx 1846 Direct3D10 (Hardware) - SSE2
Here are my settings:

Interlacing - None
Aspect Ratio - 4:3
Native - Unchecked
Allow 8 bit textures - Checked
Wait VSync - Unchecked (I got the same results both checked and unchecked)
Enable Blur Effect - Unchecked
Speedhack : 2x
EE Misc - All checked
Status Flag - Checked
Min/Max Hack - Unchecked
VU Cycle Stealing - Moderate

I got up to 40-45fps, am I missing something or that is just because of the limitations of my hardware?
Reply
#5
Try the Idle Loop-forward and INTC speedhacks, native checked (or better use 512x512 as internal res) in GSdx and allow 8-bit textures unchecked. Also you can try ZeroSPU2 as sound plugin or checking the "disable effects processing" option in SPU2-X and changing the clamp modes in "config > advanced" to none but you might need to change this one to normal or extra for a couple places where the game may hang.

But yeah basically your hardware is pretty limiting and tweaking the configuration can only help so much.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
(11-20-2009, 05:23 AM)Shadow Lady Wrote: Try the Idle Loop-forward and INTC speedhacks, native checked (or better use 512x512 as internal res) in GSdx and allow 8-bit textures unchecked. Also you can try ZeroSPU2 as sound plugin or checking the "disable effects processing" option in SPU2-X and changing the clamp modes in "config > advanced" to none but you might need to change this one to normal or extra for a couple places where the game may hang.

But yeah basically your hardware is pretty limiting and tweaking the configuration can only help so much.

Doing that I got to 45-55fps, I guess that's what my computer can give, and its actually playable Smile Ill be checking for future methods to see if I get any chance later to make it 90% : D

Thanks Koji and Shadow Lady
Reply




Users browsing this thread: 1 Guest(s)