Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX on Macbook Pro
Hi all, I was reccomended posting under the mac section to see if I can get any additional assitance...

First up let me say a COLOSSAL thank you to the devs of pcsx2, not only are some games playable thanks to this, but they look even better than how they were initially set out to be shown. You guys are awesome and this is truly a possitive step in the emulation world.

Second onto my problem, I have a 2010 Macbook Pro (i7 Mobile 620 @ 2.66ghz, 8gb ddr3, gt330m 512mb gfx) running windows 7 64bit. I'm trying to play FFX (dumped from my Aus PAL version) but am getting some pretty awesome slow down in some areas.

For the most part the game plays OK 40-50fps in towns and blitzball. Entering in and out of battle I get slowdown down to 20-30fps and the audio slow down and sound crap, but when the actual fighting begins in the battle and it comes to selecting your moves it shoots back upto the full 50fps, even with summons.

The world map is just about a joke with fps running down to around 10-20 and sound playing in slow motion. Most FMVs play relatively smooth but the sound stutters and sometimes video slows down.

After reading and reading the general sort of opinion is that the CPU would be the weak point, that would atleast explain the slow down in something more cpu intensive like the world map. I've tried running with and without speed hacks (all enabled except the mVU hacks and IOP x2, EE cyclerate is 2, VU cycle is 0) but it doesnt seem to do anything to increse the speed. Here is my config:

Version: PCSX2
GS: GSdx 3068 (MVSC 15.00, SSE41) 0.1.16
-Renderer: Direct3D 10/11 (Hardware)
-Interlacing (I keep changing this to see what looks best)
-Scaling 2x
-HW AA 2x
-Texture Filtering ON
-Allow 8-bit textures ON
PAD: LillyPad svn (r2930) 0.10.0
SPU2: SPU2-X r3117 1.4.0
-Interpolation: 1 - Linear
-Reverb: 1x
-Output Module 1 - XAudio 2
-Latency: 150ms
-Synchronizing Mode: TimeStretch
-Audio Expansion: Stereo
CDVD: cdvdGigaherz (r3006) 0.8.0
USB: Usbnull
FW: FWnull
DEV9: DEV9null

Emulation Settings:

EmotionEngine: Recompiler
IOP: Recompiler
-Round Mode: Nearest
-Clamping Mode: Full
Flush to Zero ON
Denormals are Zero ON

VU0: microVU Recompiler
VU1: microVU Recompiler
-Round Mode: Nearest
-Clamping Mode: Normal
Flush to Zero ON
Denormals are Zero ON

All features untouched

Window Aspect Ration 4:3


EE Cyclerate: 2x
VU Cycle Stealing: 0
Enable INTC Spind Detection ON
Enable Wait Loop Detection ON
IOP x2 cycle rate hack OFF
microVU hacks OFF

FFX Game Fix ON

If anyone could offer me any advice on what I can do to speed this up to as it should it would be HUGELY appreciated.


Sponsored links

Try to disable 8bit textures and the 2x AA first. I bet that's the slowdown Tongue2
I'm confused, this is windows 7, I think this should be moved to general section.
(08-16-2010, 10:14 AM)zedr0n Wrote: I'm confused, this is windows 7, I think this should be moved to general section.

I know me too zed, I posted first in general and nobody wanted to help because it's a macbook, but I thought because it was running windows 7 it was more suited there Sad I posted here just incase tho...

Users browsing this thread: 1 Guest(s)