Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX sound glitches and cutscene glitches
#1
Here are my PC specs for your analysis.
[Image: 1609623_862054267156931_233571004_n.jpg]
I'm using PCSX2 1.2.1

So,when I play FFX on PCSX2 i encounter numerous sound glitches, and during the pre-rendered cut-scenes the game slows down horribly. I thought with my specs I could run the game just fine.

Am I missing any plug-ins?If I am can you please provide links to them. And if there are some settings that I should adjust can you please post screenshots of them?
Reply

Sponsored links

#2
The sound glitches probably come with unstable fps, right?

If so, perhaps lower your resolution if you are higher than native. Consider VU cycle stealing for low fps if cpu bound. Your hardware is older, so it could be from either end.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
you can upgrade the hardware.
CPU: Intel i5 Hashwell please
RAM: 8 GB
GPU: 650 GTX or equivalent Radeon R9 270X or more
HDD: Like you want 1 TB 2 TB 3 TB and more if you want it
CPU: Intel Core i7 4790K @ 4 Ghz
CPU Cooler: Corsair H75
MoBo: MSI Z97S SLI KRAIT  
GPU: AMD Radeon R9 290X
RAM: Corsair 16 GB 1600 Mhz

Desktop
[Image: 1086677.png]

Laptop
[Image: 872520.png]
Reply
#4
First make sure you have all recommanded Speedhacks +MTVU activated. This CPU should be fast enough for FFX.
You GPU is unfortunately very slow so set the resolution to Native and turn off FXAA/FX Shader under Gsdx settings. Allow 8-bit Textures might help to (or make things worse) so try this out as well.
Reply
#5
I could play FFX on 2x with my 9400GT, which is as far as I know considerably weaker than the 9500. Perhaps you could overclock it, although it should run fine. Are you running it off an ISO?
Reply




Users browsing this thread: 1 Guest(s)