Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFXII Shadow Glitches during Cutscenes, Partial Solution
#1
Tongue 
Hello, FFXII runs perfectly for me except for one minor shadow graphical anomaly during cutscenes that's plagued me for ages, from 0.9.7 to current. Note this issue ONLY happens during in-game cutscenes, not during any other time. I'd suspect I'm not the only one with this issue.

Config Info:

Intel Dual Core E6850
nVidia GeForce 480
PCSX2 0.9.8 r4600 release and plugins
GDSX DX11
No speed hacks, but all non-GSdx settings don't matter.

I've determined this shadow problem only happens when running in non-native internal res in GSdx. I tried every other setting and .ini tweak for GSdx and nothing changed this issue. DX9 or DX11 makes no difference. The result of using 2x-6x presets is this:

   

Also note if I set MSAA to anything over 0 or 1, this compounds the weirdness, and looks like this:

   

However, using MSAA of 0 OR 1 is ok for whatever reason.

What I finally discovered is if I set a "Custom size" internal res, then I can actually use whatever I want, like 2048x2048 (this would be roughly 4x, right?), and then the cutscene shadows are *mostly* correct, and look like this:

   

(Toggle between software and hardware with F9 to see how this scene is supposed to look on a real PS2, the shadows are supposed to be transparent gray, not black, but that's not my concern at the moment.)

However, even with this custom size trick, I do still get weird shadows as can be seen in this next shot (notice ground and lower wall on left blackness):

   

The weird thing is this last error doesn't happen with the original shadow weirdness. So I suppose this is a trade-off, but in general FFXII's cutscenes are mostly shadow-freak-out-free if I use a custom internal resolution of any size and not the presets (2x-6x).

Bottom line for me and perhaps many others: use a custom internal resolution to mostly avoid this issue. Anyway, just posting this in case someone knows a better fix, and maybe this will help somebody...

Should I post this in the GSdx page or bug report page? I wasn't certain. Thanks.

Sponsored links

#2
Mine FFX-II - pal runs smoothly without any graphical issues
Heres' my config

1)Emulation

a)EE/IOP
(default)

b)VUs
(default)

c)GS
Disable framelimiter is turned on
Base - 200%
Slow - 100%
Turbo - 200%

frame skipping - constant
2 frames to draw and 2 frames to skip

d)Window - that suits your best!

e)Speedhacks - All turned Off

f)Game Fixes - FFX Video Fix and EE timing hack!

2)Plugins

a)GSdx 3693

DX10/DX11 Hardware - You might need to use Software mode to correct graphics problem!

Interlacing -Weave bff

Hardware - Logarithmic Z and Alpha Correction(FBA)


Hacks -
HW Anti-aliasing - 1
Alpha Hack - 0 or Not checked
Offset Hack - 1 or checked
Skipdraw Hack - 1

Pads and other plugins are default/

Final Fantasy x-2 PAL works best with these setting! No Graphics Problem!
FPS - 65 - 70 ~fps
[Image: recodersignature2.png]
#3
Do note that its Final Fantasy XII as in 12 not X-II which is the FF10 sequel.

I'm also getting this problem and have not tried to fiddle with any of my settings but I currently preset the emulation settings to 2 and have X5 scaling on. If turning it to native solves it like the OP said, I would but I fear that I might get eye cancer from the pixels(sorry, just one of those guys who can't stand bad graphics when you know you can get better). Is there another workaround without compromising the graphic quality?
#4
(05-15-2011, 10:12 AM)mazei Wrote: I'm also getting this problem and have not tried to fiddle with any of my settings but I currently preset the emulation settings to 2 and have X5 scaling on. If turning it to native solves it like the OP said, I would but I fear that I might get eye cancer from the pixels(sorry, just one of those guys who can't stand bad graphics when you know you can get better). Is there another workaround without compromising the graphic quality?

I fiddled with every single setting imaginable. Nothing made any difference for this shadow issues EXCEPT the setting of internal resolution in GSdx. As stated, you CAN use a higher resolution so long as you set it via the "Custom size" option.

I want to clarify, though, even when using the "Native resolution" checkbox, the shadows are still messed up. So it isn't just that upscaling causes this issue.

To summarize: Running at native ugly low-resolution doesn't fix the problem, neither does using the preset 2x-6x options, however, specifying any custom size like 2048x2048 (roughly 4x) reduces the shadow error greatly.
#5
I am playing FFX2 right now and I am experiencing the same problem. This guys original post summed up the problem so well that it's easier to bump this one.

Is there any kind of fix for this? I feel like I've fiddled with enough options by now that I'll have to deal with it.
#6
Please make your own post mate instead of reviving a nearly 2 yr old thread Smile




Users browsing this thread: 1 Guest(s)