Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS drops from 60 to 30 in Dark Cloud 2?
#1
Alright, this is frustrating as F*CK!

First of all, let me say I've waited about 6 months trying your emulator out to play this game, about every month I'd download the emulator and try it with this game. The new beta program came out, I figured it'd prolly work this time.
Apparently not.

SO, like I said in the title Dark Cloud 2 runs fine for about 10-15 seconds at 60 fps, then drops to 30 fps. Exactly 30 fps.
Now do I have settings wrong, or is my hardware not good enough? I'm almost CERTAIN it's the settings because I can run Final Fantasy 12 just fine at 60 FPS.

Your program works like a charm, just maybe not for this game. If anyone could help me on figuring out a solution to making this game run at 60 FPS, I'd greatly appreciate it.

P.S. By 60 FPS I mean full, normal speed. Like the game should run.
Reply

Sponsored links

#2
You arent using a laptop by chance are you?

If so, the performance drop is because your laptop is throttling to stop itself frying, they aren't made for that workload.

If you are using a desktop machine, you could try reducing your settings in GSDX, its possible its running out of memory.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Hah, another definite victim to accidently enabled vsync! Tongue2
Make sure to disable vsync in the PCSX2 options and also in your video card driver panel.
Reply
#4
(07-08-2010, 10:20 AM)refraction Wrote: You arent using a laptop by chance are you?

If so, the performance drop is because your laptop is throttling to stop itself frying, they aren't made for that workload.

If you are using a desktop machine, you could try reducing your settings in GSDX, its possible its running out of memory.

Yeah I'm running a desktop.

How would I go about reducing my settings? My GFX card is DX10 compatible so I'm using that right now, should I drop to DX9?
Reply
#5
(07-08-2010, 10:37 AM)rama Wrote: Hah, another definite victim to accidently enabled vsync! Tongue2
Make sure to disable vsync in the PCSX2 options and also in your video card driver panel.

I'm using the beta client, where do I go to disable it? I'm sure I didn't enable it...
Reply
#6
nope
but if your GPu is a bit weak, settings the internal res to native may help.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(07-08-2010, 11:00 AM)jesalvein Wrote: nope
but if your GPu is a bit weak, settings the internal res to native may help.

My GPU is a GTX 260, I'm sure it's not the problem. But I've set the resolution to native anyways, and I see no performance change.
Reply
#8
just go to Nvidia control panel -> manage 3D settings -> Global tab -> Vertical sync (force off).

That should be set off globally indeed, you can always set it on or appl controlled if something else need it, what hardly happens.
Imagination is where we are truly real
Reply
#9
Hmm rama is right (as is nosisab), vsync is your problem, if your videocard cant maintain 60fps it on purposely locks it down to 30 fps as a more manigable number, it does this to keep it in sync with your monitor and reduce frame tearing.

try the above suggested of turning vsync off in the nvidia control panel global settings and try again
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
Well, I know how to set up my GFX for optimal FPS, so everything is off including vsync. VSYNC IS NOT THE PROBLEM. It could be the refresh rate of my monitor, but I doubt that. Any other suggestions?
Reply




Users browsing this thread: 1 Guest(s)