Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS drops through the whole game
#1
i've been having a sort of a weird problem, a few days ago PCSX2 was workings just fine, today when i wanted to play KH 2 the FPS remains at a constant 30% or below, i've tried everything, from forcing vsync off, from the Nvidia control panel, and trying all configurations on PCSX2 but still it doesn't seem to work the way it used to.

PC specs in case you need to know
Processor: Intel Core 2 Extreme CPU X9000 @ 2.80Hz
2 GB RAM
GeForce 8700M GT

Thanks in advance
Reply

Sponsored links

#2
Check Config > CPU, under Frame limiting whether it's limiting it down to a certain low FPS or not. Change the FPS value to 0.
[Image: yunacopy.jpg]
Reply
#3
(10-20-2009, 04:28 AM)boogerthe2nd Wrote: Check Config > CPU, under Frame limiting whether it's limiting it down to a certain low FPS or not. Change the FPS value to 0.
It's already at 0, the thing is i haven't changed the configuration one bit, one day it just started to drop the FPS, still is today.
Reply
#4
Download CPU-Z and check if your CPU is running at full speed or not. Check while playing a game on PCSX2.
[Image: yunacopy.jpg]
Reply
#5
(10-20-2009, 06:19 AM)boogerthe2nd Wrote: Download CPU-Z and check if your CPU is running at full speed or not. Check while playing a game on PCSX2.
Well i'm not quite sure how i can tell if it is running at full, but i've included a screen-shot.


Attached Files Thumbnail(s)
   
Reply
#6
Look at the "core speed" it's obviously not running at the intended 2.8GHz. Try changing the power profile in windows's control panel to high performance.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
If that doesn't work, you could go into the BIOS and change the multiplier manually to 14x (as it should be at stock) and turn off Speedstep and C1E Enhanced Halt state to see if they are the culprits.
[Image: yunacopy.jpg]
Reply
#8
Well this is sort of embarrassing, i had my lap on stealth mode Blush heh, my bad guys, anyway, thanks for the help!.
problem solved
Reply
#9
I have a question...CPU-Z likes to flop back and forth on showing my cpu speeds. It will vary between the 3500 MHZ at x8 multiplier (which is what it's set to in the BIOS) to 2623 MHZ at x6 multiplier. It's incredibly strange, but my emulation speeds remain as good as always.

Edit:
Hrm...nevermind. Apparently I had something called "C1E Halt" something or other enabled in the motherboard. I may actually keep it on because it saves on idle temps, but I'm wondering if that's been the cause off all my stupid system lock ups while watching video files on my computer.
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Reply
#10
Both Intel SpeedStep and C1 Enhanced Halt state will lower your multiplier when idle to reduce power consumption and heat output. It can be a cause of instability when overclocking, though it's way more likely to be something else.
[Image: yunacopy.jpg]
Reply




Users browsing this thread: 1 Guest(s)