Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS drops when approaching a savepoint
#1
I'm trying to play Wild arms 4, my first time doing so with an emulator so I don't have to plug my PS2 to my tv. And weirdly enough whenever I approach a savepoint my framerate will drop to 45 ruining the audio and causing slowdown

This actually happens too when I go to the forest area at the very beginning (like 5 minutes into the game) where it drops to 50fps and the audio becomes all jittery. I already pressed F9 to fix the visual glitch of the text boxes being missalligned and that's about all the trouble fixing I know how to do.

So how can I keep my FPS at a smooth 60? (I honestly don't care what the fps is so long as it's stable and lets me play the game smoothly like on console.
Reply

Sponsored links

#2
posting your emulog could help Cool
Reply
#3
Please post your specs and gsdx plugin settings.
Reply
#4
All right so here's the specs according to the emulator console
Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 8108 MB
CPU name = Intel® Core™ i7-3820 CPU @ 3.60GHz
Vendor/Model = GenuineIntel (stepping 07)
CPU speed = 3.599 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 1fbee3bf
x86EFlags = 2c100000


however I don't know how to get the emulator log nor how to see the GSDX settings.
Reply
#5
MainWindow -> Configuration -> Video (GS) -> Plugin Settings

Set extra rendering threads to 3 or 4 if you use software renderer.


And use GSDX AVX as GS-Plugin (MainWindow -> Configuration -> Plkugin/Bios selector -> First Dropdown menu)
Reply
#6
Quote:So how can I keep my FPS at a smooth 60? (I honestly don't care what the fps is so long as it's stable and lets me play the game smoothly like on console.
if your desire is to maintain a smooth 60fps first, use dx11 hardware mode and limit the frame limit to 60, and use mtvu since it takes advantage of your multiple cores.( this is the best you can try to achieve a stable 60fps)
Reply
#7
(11-21-2014, 12:28 PM)white fang Wrote: this is the best you can try to achieve a stable 60fps

or he can just use his strong cpu in software mode. Especially if he gets glitches in hardware mode.



Additionally:
MainWindow -> Configuration -> Audio (SPU) -> Plugin Settings -> Synchronizing Mode: Set to Async Mix to get stable sound even if the framerate drops some fps. Then lags will be hardly noticeable if you don't look on the fps-counter.
Reply
#8
These are the default settings my GSDX was set to (also already using GSDX AVX)
[Image: 2640q43.png]
Reply
#9
And now put extra rendering threads (on the bottom) to three or four. And set Renderer to DX10(software).
Reply
#10
My renderer goes from Direct3d9 to direct3d11
Reply




Users browsing this thread: 1 Guest(s)