Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS half of what they should be
#1
Hi everyone, I'm really new here and this is actually my first post. I was wondering how can I maximize the fps at gameplay. I mean, I can emulate at 60 fps at the boot screen but as soon as I start a game it reduces to half!! That would be 30-35 fps...

I tried emulating GOW2 NTSC and The Warriors NTSC and at some parts like when I pause the game the fps are up to 60 but when I play the go down to 30-35... Imagine what it would be like with the epic fights in The Warriors...

I can play both games fine but it's like I'm playing in slowmotion.

Here are my specs:

PCSX2 0.9.7 r3113
Video Plugin: GSDx 3068 (MSVC 15.00, SSSE3) 0.1.16
Intel i3 530 2.99 Ghz
2Gb DDR3
Nvidia GT240 1GB GDDR3 128 bits PCI express 2.0
Sata 320 GB
Windows XP SP3 32bit

I have read the guides and tried many things with no change so...
Any help on how to configure the plugins or something else so I can play at 60 FPS would be much aprecciated. Thanks!!
Reply

Sponsored links

#2
play with speedhacks till you find something useful. my 2.2 can boast 60fps sometimes on GoW2 (and not just menus) when I configure it right. also set your resolution to native in gsdx
Reply
#3
I can play God Of War 2 at 60 FPS and at 1600x900 with these hacks but, of course, it's glitchy... I see red, vertical lines when underwater and sometimes Kratos is seen as a stereoscopical light. I mean, he disappears and comes back into the screen really fast. Still, it's a major improvement...

Speedhacks screenshot is attached.

   

Any other tips will be helpful.

Thank you for replying so quickly!! Now I can relive the nightmare of beating GOW2 in Titan mode!!
Reply
#4
You may have Vsync enabled, that's not a PCSX2 issue, it happens every time any application can't reach your monitor's refresh rate and the driver reduces the output to allow that synchronization, what may be as hard as half the nominal value.

The simpler way in your case is the Nvidia control panel in the Manage 3D settings, the last option. It's recommended it being globally forced off since very few applications may need it to correct some graphic misplacement (for these it can be allowed in Program settings tab).

For the lines and maybe some graphic glitches it is probably the wrong internal resolution in relation with the game. Better could be using 2x scaling, don't rely too much in your CPU and video card (actually it's not that strong for the emulator), anyway emulation and native games are totally different things, your machine can run most native games nicely but some emulated games will be too much for it if abused.
Imagination is where we are truly real
Reply
#5
Well, I haven't tried the Vsync issue yet... I'm too busy playing with fluid speed and very few corrupt graphics in some games...

Thank you guys for your support. Best regards
Reply
#6
you're using more speedhacks than me and I have a slower processor.. put ee at 2 and down VU stealing to 1. and use IOP hack
Reply




Users browsing this thread: 1 Guest(s)