Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS low, CPU not being utilized
Hello, all. I'm new and looking for a little help getting games to a playable state using the latest PCSX2.

I just got the new release, with the updated plugins. I'm using GSdx SSE41, in DX9 mode using mostly default values. I'm using a small amount of frame skip, yet I can't seem to break past 25fps in any game I try.

My specs are:

P8400 Core 2 Duo @ 2.49GHz
4GB DDR2-800 RAM
GeForce 9800M GTS 512MB

Now I know the CPU isn't an extreme edition, but I thought it should perform better than this. One thing I noticed is that according to GSdx my CPU usage is never going past 25% or so. I'm not running background tasks, and I'm in dual core mode and everything. Are there any tricks to getting PCSX2 to use my processor correctly?

FYI, the games I tried so far have been NTSC versions of Smackdown: Just Bring It, Final Fantasy X, and Gran Turismo 4.

Sponsored links

Your Graphics card is enough to render the display and so most of the work is done by your graphics card. And what you see in the GSdx window is not the actual usage of your cpu. 25% is the speed of the game that you are running
At 30fps it will be 50% and at 60fps it will be 100%.
Check your cpu usage in Windows task manager
I mean the percentage farther to the right that actually says "XX% CPU", unless that's what you're talking about and I'm just confused.

Anyway, good to know that my GPU is working well, though it doesn't explain why my performance is so poor...pretty much nothing is "playable" though FFX is listed that way in the compatibility guide.
GSdx measures GSdx cpu utilization only. GSdx does not care about the rest of Pcsx2.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Ok, first of all, 25fps is too low for that machine in ffx. You should be getting at least 60fps in the opening sequence (rather more).
If you have the new release, then the default values for each pcsx2 option will be fine (delete your pcsx2.ini and leave all settings
besides plugins on the default).
In GSdx you'll want dx9 hardware (dx10 hardware if you're on vista).

The cpu usage gsdx reports is just an indication that says if the plugins work is too much.
Low number = all is well. High number = gsdx uses too much cpu or vga power..
Unfortunately, I'm still stuck with extremely laggy performance, after setting everything to default except using DX10.
Have you tried updating to the latest driver?
I'm currently using DOX 182.05, which a lot of people consider the best currently available.

I made sure my power management was on very very high performance as well, so I don't know what to do.
It may also be so because of your cpu overheating. An overheating system will run slow no matter what.
My CPU doesn't go beyond the low to mid 40s while running the emulator, so that's not it. I just tried Kingdom Hearts, which ran fine until I got to the starting island. When I'm there, any angle that I can see a lot of the map results in a low-40s frame rate.

Not sure what's bottlenecking my system, but it's driving me crazy.

EDIT: Fatal Frame runs at low-50s mostly, with cinemas strangely running at mid to high 40s. Resident Evil 4 gets high 30s to low 40s when in motion.

All of these games I ran with no frameskip, since I really shouldn't need it.

I'm beginning to think my processor just isn't fast enough clock-wise.

Users browsing this thread: 1 Guest(s)