Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS swan dive
#1
So last night I was playing Kingdom Hearts 1, working perfectly fine. Fps was about 50-70 during fights and 50-140 during everything else. It was nice and pretty perfect. Today however, I get on and my FPS took a massive swan dive, 15fps-25fps. I don't quite know what happened but last night I think I remember something happened and I could switch between Limiter: None and Limiter: Turbo with my f4 key. Today I can choose only between normal and none. May not be anything but that's all I could think of. I am a HUGE noob to this emulator stuff.

EDIT: Also, all my set up is the same as it comes with the download. I didn't dare try to change anything due to the fact I understand practically none of it.
Reply

Sponsored links

#2
What are your system specs?

CPU? GPU? Windows 7? Laptop?
Are you playing straight from the disc?
Also-- It this PCSX2 0.9.8?
Reply
#3
Laptop w/ windows home premium. It's a brand new laptop, had it a week. Ran everything smoothly until just now. Playing an iso. PCSX2 0.9.8.

Noob to this stuff but I think this is what you mean by system specs:

System Manufacturer: TOSHIBA
System Model: Satellite P755
BIOS: BIOS Date: 07/13/11 15:48:44 Ver: AMI APTIO 2.10
Processor: Intel® Core™ i3-2330M CPU @ 2.20GHz (4 CPUs), ~2.2GHz
Memory: 6144MB RAM
Available OS Memory: 6050MB RAM
Page File: 2465MB used, 9634MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Reply
#4
Make sure your CPU isn't being trottled.

This can happen if your Windows Power Plan is not set to High Performance", or the likes.
Which can be set to happen when the unit goes from AC power to battery.

Also-- It is possible for it to become throttled if the core's temps get too high,
but I'm guessing you'd notice if it was that hot. Smile
Reply
#5
Well high performance is on, and it seems moderately warm, but nothing bad. Perhaps the core temp is high but this fan system is just brilliant, because it's just been laying on my bed, so that could be it. My last laptop would've easily overheated given that circumstance, I play with it on my lap so it'd cool off eventually. Also, I figured out how to enable turbo and it sped up my fps slightly, now it's above 30, but still not normal.

also, now for some odd reason i went to save and the game tells me I have no memory cards. This completely puzzles me.
Edit: Memory card problem seems to have fixed itself with an exit of the room and reentry.
Reply
#6
Does your laptop use Optimus technology by chance?
(dynamically switches from IGP to dedicated GPU)
Reply
#7
Where could I check this?

Oh, now that I see what it is I highly doubt I have it.
Reply
#8
Problem still not fixed even after PC cooled down, it's just chilling there at this low framerate. I went to play another game and the same fps problem occurred, much low fps than normal. So anyone know what could cause such a sudden drop in performance?
Reply
#9
I'm almost 100% sure that you have optimus technology, just try that:

Right click on your desktop -> Nvidia control panel -> 3d configuration -> Program configuration, browse pcsx2 exe and select Nvidia high performance processor.

If you want to be sure if it's that just go to the Pcsx2 .exe and right click it, if there's an option called launch with graphic processor and you can choose between 2 it's an optimus issue for sure, if not... I have no idea of what's going on
Reply
#10
It was my laptop just being WAAYYY too hot. It was around 185F. I took out my battery and let it cool for a while, and started playing without my battery in the laptop but instead just keep it plugged in. Works wonders for keeping your laptop cool.
Reply




Users browsing this thread: 1 Guest(s)