Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS troubles with Dragon Quest 8
#1
I'm new to the PS2 emulating community (though not new to emulating) and I must say it is far more difficult than any other playable emulator I have tried to get it to perfection. So far I've gotten Fatal Frame 2 to work flawlessly, but Dragon Quest 8 is giving me huge problems in large field-of-view areas such as the 1st town you start in. I've tried almost all options of speed hacks and my rig can run SOTC and MGS3 fine (still working on correcting certain textures and sounds in MGS3, but the frames are fine) my rig is as follows
AMD 9850 Black OCed @ 3.0GHz (Quad)
EVGA (Nvidia) 275 GTX
4gb RAM
Windows 7 64bit

This is how I have my emulator set up:
http://img718.imageshack.us/img718/1269/pcsx2specs.png
Reply

Sponsored links

#2
8-bit textures and internal res may be responsible for this.
disable the 1st one, and set the 2nd one to native
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Just tried that and there seems to be no difference.. I don't think it's a problem in the rendering department. Why does it hit 110 FPS when i take off the limiter, but if i limit it to 60, it has these spikes of slow-motion gameplay?
Reply
#4
(09-21-2010, 03:43 PM)mcbeefy Wrote: Just tried that and there seems to be no difference.. I don't think it's a problem in the rendering department. Why does it hit 110 FPS when i take off the limiter, but if i limit it to 60, it has these spikes of slow-motion gameplay?

My settings for that game were almost the same as yours, and it runs fine. I get 60ish fps with frame limiting off and thats on a 4850. So Im not sure what the issue is on your end but that first town is one of the most demanding areas in the game to emulate fps wise.

Anyways I suggest you turn off anti aliasing in your nvidia control panel [if it is on], and you should also run the game with GSDX directx 10. The DX10 version of Gsdx is alot better than the DX9 one for Dragon quest, you should see a 15-20% fps increase from switching to that alone.

The best version of Gsdx that I have tried for DQ8 is version 2693 btw, later versions of it did give me framerate issues in DQ8...So if you using a newer version of that plugin that could be the problem to.
Reply
#5
(09-21-2010, 03:43 PM)mcbeefy Wrote: Why does it hit 110 FPS when i take off the limiter, but if i limit it to 60, it has these spikes of slow-motion gameplay?

Probably some speedhack you have enabled, try without.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)