Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FPS way too high- games too fast
#1
Hello

So I just started with the PCSX2 today, and upon trying it for the first time, games have been running normally for the past 4 hours. During the middle of a game (FFX-2), the FPS shot up to around 100 and the game was running on fast forward. I've tried a few other games, and the same thing happens, except it will go to upwards of 288FPS.

Frame limiting is NOT disabled, nor has it ever been (I did not accidentally toggle it during a game).
All the default settings are still as they were (100, 50, 200).

How can I tweak this to slow it down? I'm out of luck, as google and the forums have been no help to me (from what I could even dig out from the depths of the internet).
Reply

Sponsored links

#2
Try pressing Tab and see if there is any change.
Reply
#3
Oh wow, it did. Thanks. What does that even toggle?? I had made the tab button one of my keys to use in the games -__-.
Reply
#4
It enabled\disables turbo mode
Config=>Emulation Settings=>GS=>Turbo Adjust.

If you press Shift+Tab,you will be triggering Slow Motion mode
Tab only is turbo mode
Reply




Users browsing this thread: 1 Guest(s)