Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Fail to modify user configuration .ini"
#1
Hi there, and first, thanks for all the effort with this awesome emulator! Truly amazing.

Ok, this already happened with 0.9.7 and is still happening with 0.9.8. Whenever I make changes to plugin config, or any other config in PCSX2 and press "Apply changes", this read message appears in the log screen.

I think maybe this has something to do with me using the old PCSX2 folders in "My documents", because after I formated my pc, reinstalled PCSX2 and it now put default folders in "Users" folder, and I don't use those, so I specified to the old ones I made backup.

Sry if that was bad explained.

SPECS:
i5 760
Sapphire 4670 512 Mb
4Gb DDR3 RAM
Reply

Sponsored links

#2
you tried to start the pcsx in admin mode ?
Reply
#3
Most accounts on windows are already administrative, should not exist any reason to run a game as "Administrator" user if the real cause of problems was not already there.

Almost all "access rights" issues are due to installing in protected folders and having the UAC set high (That combination is stupid from the beginning as long "security" is concerned, if not for the other innumerable issues, just by forcing to use the Super User over an already administrative account...)
what should be taught to new users is do the correct thing from start:

1 - Do not install games in C:\Program Files, Program Files (x86) or any "specially protected" folder. Just create a directory, lets say C:\Games and be used to install all games there, including PC games.

2 - Consider reducing or even disabling completely UAC. That feature is just annoying and in fact a hole in security instead enhancing it (just think about the absurd amount of "concessions" one must do to be able to run something to the above statement becoming clear).

The bottom line: If you need to run a game as the "Administrator"... things got already astray long ago.
Imagination is where we are truly real
Reply
#4
I suggest you use the 0.9.8 Binary package as it won't use the other user folders and most likely won't give any other problems like that:
http://forums.pcsx2.net/Thread-PCSX2-0-9...ows-Binary
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
Huh? what's the binary for? Doesn't PCSX2 install everything I need?

I can play games well, the only problem is PCSX2 can't modify, make changes on the .ini file.

Another one: How can I open saved games of 0.9.7 with 0.9.8? I'm not talking about the memory cards.
Reply
#6
The binary is all of PCSX2's files in an archive file (like a .zip). Instead of the installation process, you just extract the contents to a folder of your choosing. As suggested, be sure not to do this in a protected location (like Program Files).

When configuring PCSX2 with the initial wizard, I suggest you un-check "Use default location" for everything. That way you can be sure that the .ini files you're using are in your specified location.

Basically, what's happening is that the .ini files you're trying to change (or save changes to) are in a retricted location. Whether that be in "Program Files" (a poor choice for PCSX2), or the typical "My Documents" location, Windows will restrict your ability to save changes to files in those locations either way, unless you've given admin rights to that specific action.
Reply
#7
Already unchecked the "Read only" in all the installation folders, the problem continues. You want me to unrar the binaries in the same location? What will change then?
If it isn't in My Documents, or Program Files, where should I put the PCSX2 files into?
Reply
#8
Yay! It seems unraring the binaries in the same location and setting things up again fixed it.

For not making another topic: What should I choose, Software or Hardware Dx10 mode? It seems software mode has AA, hardware not.
Reply
#9
Use hardware mode, only some games will need software (which is slower and has no option for high resolution but is the most compatible).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
Ideally, you'll want to use Hardware mode. Hardware mode will allow you to increase the internal resolution and will also use both your CPU and GPU, so it is much faster under ideal circumstances.

Software mode is restricted to native resolution, and is powered primarily by your CPU. Typically, this will be slower in speed, but there are some games (or particular parts on them) that will only emulate well with software rendering (whether that be as far as speed, or for fixing graphical errors). Basically, rely on software mode only when you have to, but stick to hardware mode if that particular game allows it.

Where did you have PCSX2 installed? Because if it wasn't in "Program Files", then the problem was occuring with the config files being in "My Documents", which is the default location of configs when you use the installer.
Reply




Users browsing this thread: 1 Guest(s)