Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fast on TV, slow on laptop?
#1
Hi guys!

I have a problem with the emulator. I have downloaded it yesterday and created an iso from my Shadow Hearts From the New World game. I have played it on my laptop yesterday and it worked fine, 50 fps. Today I connected my laptop to the TV via HDMI (I always do that) and have continued playing the game for some hours. Now I wanted to play on my laptop again in university since I've got a huge break. But now the game runs at only 15 fps. I haven't changed any settings and I'm very confused because it worked yesterday! I only downloaded the emulator to be able to play in uni and now it doesn't work. Does anyone know what's going on?

PS: I'm home again and tried playing via HDMI and it works fine with 50 fps. Help?
Reply

Sponsored links

#2
I'll take a stab.

When you had the laptop pluged into the HDTV, did you also have the power outlet plugged in? When you took the laptop with you, did you also have it plugged into the power outlet, or no?

If you haven't try a simple restart of the computer.

If you can, what operating system are you using; for now I'll assume it's Windows 7/8. Press the windows key and type in power options and click on "Power Options" when it comes up. Make sure the power plan is set to "High performance", if it's not, PCSX2 will have some issues.

Report back when you can.
Reply
#3
That's really strange. I've had my laptop connected to HDMI and power, worked fine. I unplugged the power and it went down at full 15 fps...

I have changed the power options and now it runs at 50 fps (THANK YOU!!!) but the sound is still lagging hard. Should I change some sound options?
Reply
#4
Sure, let's take a look at your sound options.

You can take a picture and upload it, or just read off the settings you are using.

Also, since I'm already helping you, can you tell me if you setup PCSX2 using a guide or something? (I'd like to know the kind of laptop you have (or if you know, just the CPU/GPU really))

For the power outlet/power options. You should be able to force the laptop into high performance mode at all times, but the battery will drain faster. When it's Balanced or in Battery Saving more, the entire laptop places some artificial limits on itself to keep the battery going for a longer period of time.
Reply
#5
Can you show us all of your settings and list your laptop specs?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#6
Thank you SO MUCH!!!

My sound settings are in the attachment.

I have an Acer Aspire E5-571G. And I'm not a genius in terms of computers so I hope this is what my GPU is: NVIDIA GeForce 840M

I have forced the high performance option now and it works fine, just the sound still lagging.

Thank you so much for helping me out, I would have never thought of changing the power options!!

PS: And no, I haven't used any guide installing PCSX2.


Attached Files Thumbnail(s)
   
Reply
#7
Set Module to XAudio 2
Latency: 150ms
Uncheck Disable Effects Processing


See if that helps
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#8
Yes, now it works better!! Thank you! Laugh
Reply
#9
Glad is works well. You can also change from timestretch to Async Mix
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#10
Okie dokie. Let's do this, if you want, you can change the Module to XAudio2 or DirectSound, both are okay, difference won't be that noticeable. You should probably enable (Take off the checkmark) for "Disable Effects Processing". You can change the interpolation to Linear (link as to why you may want to do this here http://forums.pcsx2.net/Thread-SPU2-X-v2?page=68, read the last post)

You should probably put the Latency back to 100ms, I believe that's the standard.

On the PCSX2 window, go to Config -> Emulation Settings -> Speed Hacks Tab (Second last to the right). Make sure all recommended speed hacks are enabled, you can also enable the MTVU Hack (Multicore hack)

Uhm, just in-case. Go to Config-> Video (GS) -> Plugin Settings, make sure you are using Direct3D 10/11 Renderer and the Adapter is your GeForce 840m.

Uhm, disregard what I said, took too long to type, hahaha.
Reply




Users browsing this thread: 1 Guest(s)