Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fifa and pcsx2
#1
Hello guys,

I tried to play Fifa with pcsx2 (I tried the 10, 11 and 12) and I have the same problem

First, the FIFA logo appears, then there is the LOADING screen, and at a certain point, I feel like pcsx2 goes into an infinite loop. It takes 100% of my CPU, the graphics doesn't respond anymore, I cannot open any other window, and I'm forced to kill pcsx2 so it exits.

Has anyone had this problem before ?

Thank you !
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.
  • The emulog.txt from PCSX2/logs

Thank You.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(07-14-2014, 07:22 PM)Blyss Sarania Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.
  • The emulog.txt from PCSX2/logs

Thank You.

My computer is an Acer Aspire v3, intel core i7, nvidia GeForce, 6gigas of ram.

I'm using pcsx2 v 1.3.0, and I am on archlinux.

I tried it only on iso files.


Attached Files
.txt   emuLog.txt (Size: 2,38 KB / Downloads: 109)
Reply
#4
Hmm. Have you tried other games that work? Also have you tried with ZZOGL?
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
I thought I read somewhere that we shouldn't use ZZogl. However, when I try to use it i get this log :

Code:
ZZOgl-PG:  Calling GSopen2.
ZZOgl-PG:  Capturing ZZOgl window.
libGL error: dlopen /usr/lib32/xorg/modules/dri/i965_dri.so failed (/usr/lib32/xorg/modules/dri/i965_dri.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
The program 'pcsx2' received an X Window System error.
This probably reflects a bug in the program.
The error was 'GLXBadFBConfig'.
  (Details: serial 34 error_code 178 request_code 155 minor_code 34)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[1]    21363 segmentation fault  pcsx2

And yes, I managed to run Splinter Cell, and Splinter Cell Pandora Tomorrow, and they work greatly. Any idea ?

Thank you for taking time to help me
Reply
#6
GSdx is generally better than ZZOGL, it was just worth a shot.

What happens if you start the game in software mode?

Also are you using proprietary drivers or the open ones?
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#7
Does your laptop use switchable graphics? If so you need to ensure that the discrete nvidia card is being utilized when playing PCSX2. The Arch Linux wiki should be able to help with that as far as power settings go. You should also install lib32-nvidia-utils (as well as any other 32 bit nvidia things you might need). I'm assuming you built from source and have multilib uncommented in your /etc/pacman.conf. It'd also be a good idea to install lib32-alsa-lib so that the SPU plugin picks up the correct 32 bit library.
Reply
#8
Thanks everyone,

I think I use the proprietary graphics, however, I know that my graphic card might be badly configured...

I already use the software mode of GSdx, because I have poor performance with the hardware mode (maybe because my graphic card is badly configured...)

And yes, I have multilib uncommented in my pacman.conf, I installed lib32-nvidia-utils, but it doesn't do anything (probably because I am using the software mode), and lib32-alsa-lib was already installed.

I don't know what switchable graphics are, but I'll check the link you gave.

Thank you again !

_____
EDIT : In fact, my nvidia card has optimus technology... but I'm not sure it's well supported on linux... I keep checking you link

EDIT 2 :
I followed the arch wiki on NVIDIA Optimus, but when they give the xorg.conf (which is not still used a lot btw), my computer can't start the graphical server, startx gives something like "cannot detect screen", so I was forced to delete xorg.conf.

However, I'm not sure this is linked to the graphical stuff, it really looks like pcsx2 is not responding anymore, and I don't see why a problem of graphical card could do this (actually, I don't see why a problem like this can happen on a game and not on another...)

Again, thank you for taking the time !
Reply
#9
You must use the Nvidia along with the proprietary driver. Laptops have a bad habit at forcing the user to use Intel gpu for pcsx2. Intel gpu is not very good for pcsx2. For Linux version, compatibility is all about the gpu driver.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#10
I just looked at your warning you just posted. Indeed the system is trying to use a bad driver, hence the X error. Again, go for the Nvidia proprietary driver and make sure your system is truly using it. On an Arch system, I'm not sure how.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply




Users browsing this thread: 1 Guest(s)