Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy X Configuration Help
#1
Hey guys,

I've been working with PCSX2 for the past few hours trying to get Final Fantasy X to work properly, however it is lagging a bit.

Here's my system specs:
Intel Pentium Dual Core 2.8GHz
3GB RAM
Nvidia GeForce 8600 GT
(Let me know if you need anything more than just that.)

I was running it under Windows 7, and after messing with it for hours I tried it on Windows XP, and as I expected, nothing really changed.

Here's my current PCSX2 configuration:
[Version] PCSX2 0.9.6
[Graphics] GSdx 890 (SSE2)
Direct3D9 (Hardware), Pixel Shader 3.0, Blend tff, Native Res, NLOOP Hack, Texture filtering, Log Z, Alpha correction
[Sound] SPU2-X
Interpolation (none), XAudio 2
[BIOS] USA 1.60
[CPU]
EERec, VU0rec, VU1rec, Multithreaded GS mode, Limit (60fps)
[Speed Hacks]
x2 Cycle Rate, INTC Sync Hack, IOP x2 Cycle Rate, WaitCycles Sync Hack (I checked them all, which probably wasn't the best idea, but they didn't seem to do anything anyway).
[Advanced]
EERec - Chop/Zero, None, Flush to Zero, Denormals are Zero
VUrec - Chop/Zero, None, Flush to Zero, Denormals are Zero

As an additional note, the very first intro video is acceptable. I'm getting maybe 40-50 FPS at that point, however the intro video after starting a new game is slow...down to ~30 FPS. I've seen people able to get this running on systems worse than mine so there must be a way to do it!

Thanks for all your help! Smile
Reply

Sponsored links

#2
with that PC it should run at full speed, u got intel so u definetly have sse3 or maybe even sse4, change gsdx to highest sse possible for your processor
Reply
#3
where is it lagging? demi and summons are known hits to the CPU (demi takes my 2.2 to 5 fps)
Reply
#4
When I try to switch to a higher SSE an alert box will pop up when I try to play the game:
"This processor does not support [X]." (Where [X] is whatever I tried to use for Graphics). Thus the highest SSE I can apply is SSE2.

Also, I haven't gotten past the beginning of the game, it slows down to ~30FPS and lags during the first few intro videos. It's nearly unplayable at this point.

Oh, and it directed me to the emuLog.txt file, I suppose I'll place the contents of it here in case anyone is curious about them:

Code:
PCSX2 0.9.6 - compiled on Feb 27 2009
Savestate version: 8b400004
x86Init:
    CPU vendor name =  GenuineIntel
    FamilyID  =  4
    x86Family =  Intel(R) Pentium(R) D CPU 2.80GHz
    CPU speed =  2.803 Ghz
    Cores     =  2 physical [2 logical]
    x86PType  =  Standard OEM
    x86Flags  =  bfebfbff 0000641d
    x86EFlags =  20100000

Features:
    Detected MMX
    Detected SSE
    Detected SSE2
    Detected SSE3
    Not Detected SSSE3
    Not Detected SSE4.1

Hotkeys:
    F1  - save state
    (Shift +) F2 - cycle states
    F3  - load state
Resetting...
Ready
Resetting...
Ready
Bios Version 1.60



**************
rom2 NOT FOUND
**************






**************
erom NOT FOUND
**************



Framelimiter rate updated (UpdateVSyncRate): 60.0 fps
MTGS > Thread Started, Opening GS Plugin...
MTGS > GSopen Finished, return code: 0xffffffff
Reply
#5
try this in pcsx2.ini:
Code:
[Cpu]
Options=1137
sseMXCSR=65472
sseVUMXCSR=65472
eeOptions=1
vuOptions=1
SpeedHacks=9
VUCycleHack=1
[Hacks]
EECycleRate=1
IOPCycleDouble=enabled
WaitCycleExt=disabled
INTCSTATSlow=disabled
VUCycleSteal=0
IdleLoopFF=disabled
ESCExits=disabled
vuFlagHack1=disabled
vuFlagHack2=disabled
vuMinMax=disabled
vuFlagHack=disabled
Reply
#6
(08-15-2009, 08:59 PM)Saiki Wrote: try this in pcsx2.ini:
Code:
[Cpu]
Options=1137
sseMXCSR=65472
sseVUMXCSR=65472
eeOptions=1
vuOptions=1
SpeedHacks=9
VUCycleHack=1
[Hacks]
EECycleRate=1
IOPCycleDouble=enabled
WaitCycleExt=disabled
INTCSTATSlow=disabled
VUCycleSteal=0
IdleLoopFF=disabled
ESCExits=disabled
vuFlagHack1=disabled
vuFlagHack2=disabled
vuMinMax=disabled
vuFlagHack=disabled

Unfortunately this didn't make things too much better. It did raise the FPS during the intro video from ~30 to ~35 though. Also, I have realized that it slows down when there are many people on screen. It's nearly playable when I'm walking around alone.
Reply
#7
there's no way I should be running faster than you.. tried the latest GSdx?
Reply
#8
Well, I just tried running FFX on my laptop and it worked well. My laptop was able to run PCSX2 with the latest GSdx, however my desktop is not. Everytime I try running PCSX2 with my Graphics as something other than GSdx 890 (SSE2) it says my CPU does not support it...
Reply
#9
http://pcsx2.dyndns.org/vc10/vcredist_x86.exe
http://pcsx2.dyndns.org/pcsx2-r1627-vc10.7z
http://pcsx2.dyndns.org/GSdx-r1617-vc10.7z

try these (pulled these from gabest's page)
Reply
#10
I'm still getting an alert box informing me that my CPU does not support SEE 4.01 or SEE 3.01. I placed the w32pthreads.dll file in both the root directory of PCSX2 and the plugins directory (wasn't sure where it went). Sorry if I didn't use the files correctly, I'm new to this.

EDIT: I'm going to restart my computer then test it. That may work...
EDIT: Just restarted my computer and tested it again, same thing. It's still reporting that my CPU does not support it.
Reply




Users browsing this thread: 1 Guest(s)