Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy X - Dots/Holes Problem
#1
Final Fantasy X runs fine on my machine, except for a few graphical glitches.

First, dots/holes appear in many surfaces, particularly faces:

   

I tried disabling all Speedhacks, but this had no effect.

I checked http://wiki.pcsx2.net/index.php/Final_Fa...own_Issues and couldn't find any matching issues; the closest is

PCSX2 Wiki Wrote:"Dirty" Textures

* Type: Minor
* Affected Game Versions: All
* Description: Small black lines and dots visible at the edges and corners of texts and images.
* Solution: Unavoidable side effect of using a custom Internal Resolution and/or Texture Filtering. Either set GSDX to Native or disable Texture Filtering (see GSDX page).

so I tried setting D3D Internal Resolution -> Original PS2 resolution to Native and disabling Texture Filtering, but that just made the effect even worse, with the dots/holes even bigger:

   

Anyone know what the problem is or how to fix it? Thanks.

Sponsored links

#2
(12-29-2013, 07:00 AM)Puck Wrote: Final Fantasy X runs fine on my machine, except for a few graphical glitches.

First, dots/holes appear in many surfaces, particularly faces:



I tried disabling all Speedhacks, but this had no effect.

I checked http://wiki.pcsx2.net/index.php/Final_Fa...own_Issues and couldn't find any matching issues; the closest is


so I tried setting D3D Internal Resolution -> Original PS2 resolution to Native and disabling Texture Filtering, but that just made the effect even worse:



Anyone know what the problem is or how to fix it? Thanks.

Okay, the issue you are showing in your screenshot is not that one from the wiki. This is something I've never seen.

Please provide your pc specs, and maybe screenshots of your configurations(config-> emulation settings), like ee/iop, vu, speedhacks.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#3
I wanted to add onto this. I'm not having the issue so I'll reveal my setup and you can try that and see if it helps your issue. I'm using the FFX International version though, but that shouldn't affect emulation issues too much.

Version:
PCSX2 v5773 on Dec 23, 2013 from the SVN.
Final Fantasy X International, Disc ID -- SLPS_250.88;1

I'm using Automatic Gamefixes and the WideScreen Patches that come with the default SVN download.

Other specs are in signature. From my preliminary analysis, this may be an issue of outdated drivers or outdated DirectX; possibly even outdated drivers for some of your other hardware like motherboard drivers or bad RAM; any number of things but we won't know till we get more info on it.

Settings here:
EE-IOP
VU Settings
GS-Settings
GS-Window
SpeedHacks
#4
Those should be the optimal settings. ONLY:

For international version, EE/IOP clamping mode needs full. For NTSC, it's the VU clamping. Per this:

The Wiki Wrote:Reverse controls in some Places

Type: Minor
Affected Game Versions: All
Description: Reverse controls in some places (will move right to left)
Solution: If you're playing NTSC-U version, change VUs Clamping Mode. Else if you're playing International version, change EE/IOP Clamping mode (to Full).

So I don't think you have to have both clamping modes maxed, just depends on version.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#5
Heh, I always set both clamping modes for VU (Full) and EE/FPU (Extra + Preserve Sign) that way unless I have problems. Typically unless it is very specific games that work the other way (have to set it to a different thing) then I'm usually good. Honestly I should do a livestream of FFX International at 3x scaling. Looks REALLY gorgeous and probably rivals that overpriced 'HD Remake' they shoved out the door with barely any improvement. Lots of hype but having the devs think that fans want FFX-3 (unless they really are that vapid/shallow even in Japan) makes me lol.

No thanks Squeenix, now get to work on a FF6 3D remake nao! =D

I just figured I'd post the settings that I am using (without issues) so that the OP could take that into consideration and try to mimic my settings to see if they continue to have their issue.
#6
Odd problem that one, might just vary between graphics cards, on other computers ive noticed drastic lags when fire or demi is cast, missing textures might be the drivers or something random like that, try updating them, might just sort it out, though definitely back up the old ones in case it messes up you're current set up, thats the only thing i can think of.
#7
(12-29-2013, 08:54 AM)darkwraith007 Wrote: Settings here:
EE-IOP
VU Settings
GS-Settings
GS-Window
SpeedHacks

I found the solution to the problem Biggrin, and it wasn't any of those. Instead, for some reason changing the renderer in the GSdx plugin from Direct3D10 to Direct3D9 fixed the dots/holes in FFX, even though Direct3D10 works fine otherwise and results in significant speedup (compared to Direct3D9) for some other of my games.

Anyway, thanks for you guys' help. Smile

(12-29-2013, 07:03 AM)Blyss Sarania Wrote: Please provide your pc specs, and maybe screenshots of your configurations(config-> emulation settings), like ee/iop, vu, speedhacks.

In case this helps anyone else having a similar problem, my specs are

Intel Core i5 460M 2.53-GHz
Intel HD Graphics (Core i5)
Win7 64-Bit

PCSX2 1.0.0 r5350
GSdx 5334 (MSVC 16.00, SSSE3) 0.1.16

all EE/IOP settings were at default:
* EmotionEngine: Recompiler
* IOP: Recompiler
* Round Mode: Chop / Zero
* Clamping Mode: Normal

all VUs settings were at default:
* VU0: microVU Recompiler
* VU1: microVU Recompiler
* Round Mode: Chop / Zero
* Clamping Mode: Normal

Speedhacks:
* I tried enabling and disabling all speedhacks; made no difference
#8
(12-30-2013, 12:22 AM)Puck Wrote: I found the solution to the problem Biggrin, and it wasn't any of those. Instead, for some reason changing the renderer in the GSdx plugin from Direct3D10 to Direct3D9 fixed the dots/holes in FFX, even though Direct3D10 works fine otherwise and results in significant speedup (compared to Direct3D9) for some other of my games.

That is weird.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#9
hmm, could be a driver issue then. you could see if a newer driver is available by going here: http://www.intel.com/p/en_US/support/detect
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#10
Sorry to necro such an old thread but I need to know: Has anyone else reported having this problem? I need to know because I'm thinking of moving it to the 'Fixed Issues' section of the wiki.
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU




Users browsing this thread: 1 Guest(s)