Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy X (Low FPS)
#1
I've tried everyting I can to make my FFX game run smoothly. At any given point I will be running at a smooth 60 FPS, then suddenly I will drop down to 21 FPS. This varies from time to time in where it happens in the game. I have a really nice computer, so I shouldn't have this many problems. Any suggestions? Is this happening to other people?

My settings:

-GSD x10
-P.E.Op.S SPU2
- Linuz ISO

-AMD Phenom 9750 Quad Core, 2.432 Mhz, every box checked, Limit FPS
- EE sync hack default cycle rate
Reply

Sponsored links

#2
You're computer is good for PC gaming, but emulating an advanced console such as the PS2 is a different story. The recommended speed is a clock rate of at least 3.2GHz on a dual core (more than 2 cores aren't supported), but FFX is one of the lesser demanding games so you should get full speed or close to it. What is your video card?

These settings should help:
Firstly, make an ISO of your disc using ImgBurn, and then use the Linuz Iso CDVD plugin to access the ISO.
Second, if you haven't gotten the latest beta of PCSX2 and the latest revision of GSdx, get those at the link below.
PCSX2 beta thread: http://forums.pcsx2.net/thread-3716.html
GSdx thread: http://forums.pcsx2.net/thread-3031.html

Depending on your video card, you may benefit from ticking the "native" box and the "Allow 8-bit textures" in GSdx.
You should get a good speed boost from putting "VU Cycle Stealing" at moderate (2 notches) in the speedhacks.
Just try that for now.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#3
Setting "VU cycle stealing" to moderate will actually make some parts of the game very glitchy, set it to "slight" only. "x1.5 cycle rate" or "x2 cycle rate" speed hacks might have a good boost along with "idle loop fast-forward". Also using the SPU2-X sound plugin might be faster.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
(08-12-2009, 05:21 AM)Shadow Lady Wrote: Setting "VU cycle stealing" to moderate will actually make some parts of the game very glitchy

That must be one of those region specific problems. I played the PAL version with VU Cycle Stealing set to moderate without any problems.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#5
(08-12-2009, 04:51 AM)Larfin_Man Wrote: You're computer is good for PC gaming, but emulating an advanced console such as the PS2 is a different story. The recommended speed is a clock rate of at least 3.2GHz on a dual core (more than 2 cores aren't supported), but FFX is one of the lesser demanding games so you should get full speed or close to it. What is your video card?

These settings should help:
Firstly, make an ISO of your disc using ImgBurn, and then use the Linuz Iso CDVD plugin to access the ISO.
Second, if you haven't gotten the latest beta of PCSX2 and the latest revision of GSdx, get those at the link below.
PCSX2 beta thread: http://forums.pcsx2.net/thread-3716.html
GSdx thread: http://forums.pcsx2.net/thread-3031.html

Depending on your video card, you may benefit from ticking the "native" box and the "Allow 8-bit textures" in GSdx.
You should get a good speed boost from putting "VU Cycle Stealing" at moderate (2 notches) in the speedhacks.
Just try that for now.

my video card is an ATI Radeon HD 4650. I'm running on Vista Home premium x64. AMD Phenom 9750 Quad-Core Processor. 8 GB Ram. I'll give the PAL Version a try.
Reply
#6
I hope you have a PAL version handy, 'cos we aren't fans of pirates. Besides, it's not at all worth getting a different version of the game just so you can set a speedhack one notch more >_< As long as you setup the settings right, you should get a playable speed.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply




Users browsing this thread: 1 Guest(s)