Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy X freezing problem...
#1
Edit:
Problem is solved. Thank you all who helped.
__________________________________________________________________________
NOTE:** SPOILER IN 1ST PARAGRAPH.

I have been playing this game for a while, and I am now towards the end of the game after you defeat Sin's left and right wing along with his core. Afterwards Sin falls down, but then recovers.



When I continue with the story a CGI cutscene (or a 3d cinematic as some people call it) occurs. My game freezes and it keeps replaying the same frame continuously at 60 fps. My game has worked perfectly before this, except with the occasional weird backwards facing bosses and inverted analog stick controls in a specific few rooms.. Anyways I've tried re-ripping the ISO off my disc several times, I've tried cleaning my disk and using it, I've messed with several settings in pcsx2, but to no avail. I've tried using the manual game fixes such as the "Skip MPEG hack," "OPH Flag hack," and lastly the "EE timing hack" as a last source of desperation. The skip MPEG hack will not skip the cutscene. I've tried frame skipping to see if I could skip that specific frame as well.

By the way, I am using version 0.9.8.
If someone could help me with this issue I would greatly appreciate it.
I have searched everywhere on the internet for at least 6 hours now, and I'm kind of desperate. Haha..
Thank you to anyone who could contribute to my problem.
Reply

Sponsored links

#2
PCSX2 settings? Plugin settings? Any kind of error in the console log window when you got the problem?

Make sure you try from your last memcard save and not save state after you change settings if you've been using them.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(07-13-2011, 06:56 PM)Shadow Lady Wrote: PCSX2 settings? Plugin settings? Any kind of error in the console log window when you got the problem?

Make sure you try from your last memcard save and not save state after you change settings if you've been using them.

As for emulation settings (I think that's what these are) I have it preset to
2. I unchecked the preset and left the settings the same to try different gamefixes and frame settings.

My plugins are:

GS: GSdx 4600 (MSVC 15.00, SSE2) 0.1.16 [gsdx-sse2-r4600]

PAD: LilyPad svn (r4510) 0.10.0 [lilypad-r4600]

SPU2: SPU2-X r4600m 1.4.0 [spu2-x-r4600]

CDVD: cdvdGigaherz (r4510) 0.8.0 [cdvdGigaherz]

USB: USBnull Driver 0.7.0 [USBnull]

FW: FWnull Driver0.7.0 [FWnull]

DEV9: DEV9null Driver 0.5.0 [DEV9null]



As far as the console log I see this, but nothing that says error.

(pxEvtQueueTongueauseCoreThread) Event completed in 192ms
Protected page @ 0x001f9
Sound:Wave Entry. (wave)
Sound:Wave Entry. (wave) 췍Sound:Wave Delete. (wave)
Sound:Wave Delete. (wave)
Sound:Wave Delete. (wave)췍Sound:Wave Delete. (wave)
Sound:Wave Delete. (wave)ysmem
Sound:Wave Delete. (wave)
Sound:Wave Delete. (wave)
Sound:Wave Delete. (wave)
Sound:Wave Delete. (wave)
Sound:Wave Delete. (wave)
Sound:Wave Entry. (wave)
Uncounted Manual block @ 0x00100C18 : size = 2 page/offs = 0x00100/0xC18 inpgsz = 8
Uncounted Manual block @ 0x00100C20 : size = 7 page/offs = 0x00100/0xC20 inpgsz = 28
Uncounted Manual block @ 0x00100C3C : size = 1 page/offs = 0x00100/0xC3C inpgsz = 4
Protected page @ 0x00285
Protected page @ 0x00284
Pagesplit @ 00284FF4 : size=3 insts
Protected page @ 0x00159
Protected page @ 0x0015f
Pagesplit @ 00158FF4 : size=3 insts
Protected page @ 0x0015d
Protected page @ 0x0015e
Pagesplit @ 0015AFE8 : size=6 insts
Pagesplit @ 00252FD0 : size=12 insts
Pagesplit @ 0015EFE4 : size=7 insts
Pagesplit @ 0015CFE8 : size=6 insts
Reply
#4
upgrade to v2.0 of SPU2-X you will have much better reverb
find it here http://forums.pcsx2.net/Thread-SPU2-X-2-0
just put it in plugins folder and chose it in plugin\bios selector
Reply
#5
(07-13-2011, 08:43 PM)abdo123 Wrote: upgrade to v2.0 of SPU2-X you will have much better reverb
find it here http://forums.pcsx2.net/Thread-SPU2-X-2-0
just put it in plugins folder and chose it in plugin\bios selector

My pcsx2 folder does not have a plugin folder, do I make one or put it in the bios folder?


Edit: nevermind I realized I had to go to program files.
silly me.

My game still freezes at the same spot.
However the game runs even more perfectly than before, and I didn't think that was possible. Lol. Is there no way to just skip the cutscene?

Reply
#6
This is so frustrating. Nothing I do works. Sad
I'm almost considering giving up, 50+ hours of playtime wasted. >_<
Reply
#7
What cutscene does it freeze at?

I remember in Kilika the sending scene always botches up unless i was running 0.9.6 (that was back with r1888 however)
Intel Core i5-4690k @4.5ghz
Samsung 16GB DDR3 @2000mhz
GeForce GTX 680 4GB
Windows 7 x64
Reply
#8
If you find no other solution, I believe code archive disks, like Codebreaker, have codes stored that allow you to skip the FMVs in Final Fantasy games.

If you don't own any of those disks, though, you could look up the code online and put it in a .pnach file (although don't ask me how to do it, as I haven't).
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#9
(07-14-2011, 06:21 PM)hellbringer616 Wrote: What cutscene does it freeze at?
I remember in Kilika the sending scene always botches up unless i was running 0.9.6 (that was back with r1888 however)

It freezes during the CGI cutscene after I kill Sin's left and right fin, and then his core. It shows a cutscene of sin falling down and then getting back up and perching on a building on Bevelle. Afterwards you have to go on top of the airship, and that's when the cutscene starts. It just zooms up on sins face and then it freezes.
(07-14-2011, 08:47 PM)MyDreamName Wrote: If you find no other solution, I believe code archive disks, like Codebreaker, have codes stored that allow you to skip the FMVs in Final Fantasy games.

If you don't own any of those disks, though, you could look up the code online and put it in a .pnach file (although don't ask me how to do it, as I haven't).

I own an Action Replay, though I have not ever used it on PCSX2. Will that work and does it work the same way as it would on my console?
Reply
#10
Okay, try turning off all speedhacks (if any)

And set your EE/IOP Clamping mode settings to either extra +preserve sign, or full

and clamping mode under VU's to the same. I know that those fix the backwards battle issues. (at the cost of performance) maybe it will help.
Intel Core i5-4690k @4.5ghz
Samsung 16GB DDR3 @2000mhz
GeForce GTX 680 4GB
Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)