Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy X sound speed issue
#1
Hello. I am having an issue with my copy of Final Fantasy X and it's sound in the game. For some reason the sound will slow down and speed up for no reason in some areas sounding like it were being played by a DJ or something. I tried the game in it's normal disc form and ripped it to an iso and also tried many different sound/cpu/gpu options and plugins and none made this issue go away while some also made crackling so I don't know where to find the problem here.

Here are my pc specs:

CPU: Intel Q6600 Quadcore @ 2.4ghz
GPU: EVGA 9800GX2 (1GB VRAM) with a minor overclock
RAM: Corsair 4GB DDR2 800mhz
OS: Windows Vista 64bit with service pack 2

in th options I run the game with Direct3d9 (hardware) at 1360x768 fullscreen with interlacing and 16:9 ratio and vsync with everything checked except the blur and windowed.

With sound I have tried 3 different plugins with setting combo's that only made things either crackle or go back to normal.

With CPU I tried frame skipping and frame limiting which didnt do anything.


So again I dont know what to do here. I tried many different combinations of these settings but I'll hear some mroe to try and get this game working again.
Reply

Sponsored links

#2
the sound slowdown or speedup is normal, it just tries to stay in sync with the emulation speed of the game. you can try to disable timestretching/scaling in the settings of your spu plugin, but as you already experienced, this will create crackling sound, when the fps falls below 60.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#3
Are you sure it's supposed to sound like that though? Because on the PS2 itself I don't ever recall it sounding like a techno remix or something with what's going on here. I mean it's really bothersome because the PC here that I have is nearly top-notch so I mean it's kinda ridiculous how this game is dropping below 60 at all. Let alone trying to figure out how the PS2 made it run fine is a mystery to me.

I could try to use the sound recording or even use fraps or something and make a video or whatever and put it on youtube or wherever for you to view so you can see exactly what I mean how this is really buggin me. Would you like for me to show you a demo of what this sounds like?
Reply
#4
if these sound slowdowns happen exactly when your fps drop below 60, then it's perfectly normal. the ps2 just runs the game natively on its hardware, it doesn't have to emulate and sync a complex combination of several processing units before being able to run the game, the pc has to. even my system is not top-notch when it comes to pcsx2, i get minor slowdowns with quite some games. try dx10 (hw) as your gsdx renderer and disable vsync, the 2.4ghz q6600 should be powerful enough for ffx, perhaps you'll need some slight speed hacking with "vu cycle stealing". from my own experience the full summoning animations (especially shiva) seem to be quite good for benchmarking your setup with this game.
CPU Core i5-3570K@3.4GHz | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
Reply
#5
use ZEROspu2 with FFX, see it is still happens, mine doesn't drop below 50/60 (I have both PAL and NTSC) very often
Reply
#6
I tried the ZEROspu2 plugin using realtime mode on and off by itself then did the same with time compression and combined the two and that did nothing. My game runs at minimum 40 fps which is where the sound gets really bad and at 55fps is where it gets slowed down to like 70% or so. I ran the game in directx10 mode and it did nothing except forced it in window mode.

When my fps gets to 40 thats when I can literally hear the sound at about 5-10% of it's normal speed so I can hear say a ding sound like "d i i i i i i i i i n n n n n n n g g g g" or something similar like it's being slowed down dramatically but the FPS is at a normal speed so I'm thinking it's a plugin issue somewhere.
Reply
#7
Peops worked fine for me... but with a more powerful pc configuration.
Reply
#8
You could use P.E.Op.S and uncheck "thread mode" it'll get out of sync but sound much better Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
ok, I'm gonn toss in my 10cents once again


EE 1.x and IOP x2 seem to do the trick for me, my processor is slower, so yours shouldn't have any problems
Reply
#10
(08-09-2009, 01:11 AM)Shadow Lady Wrote: You could use P.E.Op.S and uncheck "thread mode" it'll get out of sync but sound much better Tongue2

YES! The strange mystical DJ finally left the building! The one option out of 100 I havent tried and it's the one that works. Ahhh.... yeah it is a bit out of sync by 1/3 of a second but I'll take that over someone messing with my sound through a turntable any day.

Thanks so much. Now if there's any way to make it in sync again this would be the icing on the cake.
Reply




Users browsing this thread: 1 Guest(s)