Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy XII
#1
Hi. I've started using Pcsx2 few days ago after long long break. The first game which i wanted to play was Final Fantasy XII. It is working ( in my opinion ) too slow and music is lagging. I haven't changed anything in settings, but maybe some changes will help.

These are my computer specs:
ATI RADEON HD 3800 ( 512 mb )
Intel Core 2 QUAD Q6600 2,40 GHZ
2 GB RAM
Plugins haven't been changed at all since instalation.
Reply

Sponsored links

#2
Your CPU is really slow for PS2 emulation.

The first step I would recommend is getting version r4866 or higher from here. Set it up, and go into Config>Emulation Settings>Speedhacks. Tick all the checkboxes (Except Fast CDVD), slide EE Cyclerate up to 3, and VU Cycle Stealing to 1.

Is it at full speed then?

If not, what at the EE% and GS% at the top of the screen when you get slowdowns? Your GPU is also weak for PS2 emulation, but might work at native with FFXII.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#3
get the latest rev, and enable MTVU before trying to mess with vu cycle stealing.

FF games suffer from vu stealing.
Reply




Users browsing this thread: 1 Guest(s)