Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy XII PAL CGI cutscene problem
#1
I'm having a problem with the cutscenes in ff xii, during the cutscene the screen will flicker black every now and then. It only appears to happen with hardware mode (both dx11 and dx9), it doesn't happen in software mode. disabling speedhax doesn't help.

I'm running 1.0.0, hardware:
AMD phenom 2 965 3.4 Ghz
AMD 6850
4 Gb RAM
Windows 7 64 bit

Sponsored links

#2
For some akward reason, the PAL versions of both FF XII and X have their FMVs encoded diferently than their NTSC counterparts. I also was using the PAL version of the game and was having a very slight sttutering as well as noticeable interlacing (more so in FF X), and I can assure you that these problems are not present at all in the NTSC version of the game, which runs wonderfuly and transitions from ingame to FMVs flawlessly.
#3
PCSX2 1.0 has problems with FF series FMVs in all game versions other than NTSC-U. Not only PAL, FFX International (NTSC-J) FMVs suck as well. I dunno what PCSX2 team does recently but they seem to be a bit lazy to test on other game versions.

As far as I know there is a hack in recent svns that automatically switches GSDX to software mode when PCSX2 detects a FMV.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
#4
(09-25-2012, 01:33 PM)Livy Wrote: PCSX2 1.0 has problems with FF series FMVs in all game versions other than NTSC-U. Not only PAL, FFX International (NTSC-J) FMVs suck as well.

Not true. At least with later versions of the emu. I was playing FFX international just a moment ago and FMVs look wonderful.
#5
you have 2 options.

while the video is running, press F9 to toggle in to software mode, this should work much better, or get the latest SVN version and tick the box in the game fixes section which says something along the lines of "switch to software mode during FMV's"

If it isnt there its either under the GS tab or Speedhacks. I've never actually used/seen this option since its been added so excuse the inaccuracy in direction ;p
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#6
/to terminento You're kidding? The FMVs when Tidus meets Wakka, Kimahri battle, Sin attacks S.S Likki, Mi'ihen Operation... All of them blink unless you switch to software mode.

Tested on PCSX2 1.0.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
#7
That's odd, I just got to Wakka's and pissed Kimari's cutscenes and it was just fine. But it might be that I'm using SVN v5418 and have automatic fixes on. Maybe it has been solved already?
#8
(09-25-2012, 04:28 PM)refraction Wrote: If it isnt there its either under the GS tab or Speedhacks. I've never actually used/seen this option since its been added so excuse the inaccuracy in direction ;p

It is the last item on the gamefixes tab Smile
#9
(09-26-2012, 02:57 PM)rama Wrote: It is the last item on the gamefixes tab Smile

Ta ;p ill try and remember that lol
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#10
(09-25-2012, 04:28 PM)refraction Wrote: you have 2 options.

while the video is running, press F9 to toggle in to software mode, this should work much better, or get the latest SVN version and tick the box in the game fixes section which says something along the lines of "switch to software mode during FMV's"

If it isnt there its either under the GS tab or Speedhacks. I've never actually used/seen this option since its been added so excuse the inaccuracy in direction ;p

I had just exactly the same problem MentorK had !!

Switching to manual gamefixes or pressing F9 key did the trick... but errr...

EDIT: correction, manual gamefix did not WORK.. pressing F9 key however did !! Using PSCX2 r5452 !
Or enable both FFX video fix + GSdx software rendering = SUCCES ..but won't turn back to HW automatical !


Using manual game fixes will that not undermine the compatibility of other games that might need certain fixes !? And do i have to set gamefixes back to auto ?

Or can i leave it just at that ?

Hints/tips/tricks and guidelines much appreciated recaption Happy ?

cherrriepoppers
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 965BE@4.1GHZ stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1




Users browsing this thread: 1 Guest(s)