Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy XII Questions + Thanks.
#1
Hi first off I just want to say I have been playing some FF12 using PCSX2 r1888 as my PS2 no longer works, and just want to say thanks to the people who made this emulator cos I know how hard it can be to program things. Tongue

Here are my setting so far:

PCSX2 beta r1888

GSDX SSSE3 0.1.14
1680x1050 60Hz
DX9 Hardware
Pixel Shader 2.0
16:9
1680x1050 D3D
NLOOP hack
Texture Filtering
Aplha Correction

P.E.Op.S. SPU2 1.9.0
Loud
No reverb
Gaussian Interpolation

All settings in CPU on, incl. VU, Micro VU, HT

All speed hacks on max aswell


This is my rig:
Intel Core 2 Duo E2160 @ 3Ghz from stock 1.8Ghz Tongue2
4GB DDR2 800
ATI HD 3850


I have a few questions / problems though:

1) All in all the game runs quite well around 99-100% but in extreme cases goes down to about 80%. But for some reason when running or walking in some places it will seem as though the fps has dropped loads but I look at it and it says 99-100% I then turn around and its back to normal but the fps hasn't indicated a change... turn back around and it lagging again but with 60fps... strange... tell me if I need to explain this better.

2) I can't for some reason get full screen mode in DX9 using GSDX 0.1.14 SSSE3. I can if I select my max res in the config but then I can't exit in and out of windowed mode by pressing Alt-tab. I can enter full screen mode in DX10 however (but I can't use that because I get some textures missing in game).

3) After spending quite a few days I have got the settings pretty much as well as I can... but in cutscenes the picture and sound keeps freezing every 5-10 seconds not sure why and I tried the other plugins... ZeroSPU and SPU2 and they make the sound worse everywhere else.

4) Where can I get GSDX 0.1.15 from? And other plugins cos they seem so hard to find.

Thanks if anyone can answer my questions.
Reply

Sponsored links

#2
1) using speedhacks tends to fake FPS display in gsdx window
2)Afaik, it works only in DX10 mode. Try updating your dx10. it may help
3)SPu2-X worked perfectly for me
4)http://pcsx2.net/files/22315
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
well lets start thats gonna be long....
1) dont use nloop hack its for ff10 as i know... or at least have at gray
2) spu2-x works just fine with this game trust me... just pick the latest version (its in the plugins section on the forums i think....)
3)u dont need to use micro vu for this game to work it will just slow u down.
4)now the hard part... speedhacks: well NEVER NEVER NEVER just NEVER use all of them lol. u just kill everything. disable them all and try only 1 of them at each time look if it will give u more fps (and also if u see the diference in the movement of the player cause as u saw if u raise the vu cycle stealing at max it reports wrong fps) if it will give write it down somewhere and go on with the other speed hacks. when u find the ones that actually give speed (they dont need to be maxed Wacko some times putting it in the middle its better)
5)sound keeps freezing cause u use them all those speedhacks OMFG
6) in my opinion also using full screen mode with r1888 isnt the best u can do.... and not using d3d10 just to have full screen isnt the best u can do cause d3d10 is the most stable and fast.

ps: if u still got problems after all those i will kill my self LOL Tongue

(for jesalvein) the only speedhack that actually fakes the fps is the one i mentioned in part 4, or at least that one in everygame with every settings combination i have tried tends to do it if i set it at max
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#4
Ok thanks for the input I will give that a try later.
Reply
#5
Hi I am back and I tried the things you said to do...

It turns out it was the VU Cycle stealing that was making the fps higher than it actually was, anything higher than the first ON setting and it just lies. The sound I have sorted out by using SPU2-X as you have said.... thanks.

But I am still having some issues regarding fps... normally its at 99-100% but in the first big town it drops to about 60-70%... now I tried doing what you said with the speed hacks but tbh the difference between them all is not much:

SPEED HACKS:
ALL OFF: 63%
ONE ON AT A TIME: 62-64%
ALL ON: 64%

So not sure what to do to get more fps!... oh and turning the res down to native 512x512 makes no difference to fps.

Here are my setting so far:

PCSX2 beta r1888

GSDX SSSE3 0.1.14
1680x1050 60Hz
DX9 Hardware
Pixel Shader 2.0
16:9
1680x1050 D3D
NLOOP hack
Texture Filtering
Aplha Correction

Using SPU2-X XAudio2 5.1

All settings in CPU on, incl. VU, Micro VU, HT

All speed hacks on max aswell


This is my rig:
Intel Core 2 Duo E2160 @ 3Ghz from stock 1.8Ghz Tongue2
4GB DDR2 800
ATI HD 3850

Thanks.
Reply
#6
Your internal resolution is WAY TOO high for your graphics card, which is most probably the cause of your low speed. Change internal resolution in GSdx to 1024x768 or something and see how speed is then.
Also set Pixel Shader to 3.0
[Image: newsig.jpg]
Reply
#7
(02-14-2010, 05:10 PM)Bositman Wrote: Your internal resolution is WAY TOO high for your graphics card, which is most probably the cause of your low speed. Change internal resolution in GSdx to 1024x768 or something and see how speed is then.
Also set Pixel Shader to 3.0

Yeah I tried that and it still only goes 65% in the town area. Also I can't change the pixel shader setting to 3.0 its greyed out on 2.0.
Reply
#8
Something is very wrong there, your card supports up to pixel shaders 4. My guess would be bad/broken/outdated drivers or outdated DirectX.
Get the latest here: http://www.microsoft.com/downloads/detai...laylang=en
[Image: newsig.jpg]
Reply
#9
Hmm... strange I just updated my DX10 drivers on that site (to get SPU2-X Audio working) and it said August 2009 [20MB]. I wondered why the date was so long ago... where did you find that... is that the latest revision then?

Cheers. Downloading it now.
Reply
#10
But surely I should be able to use Pixel Shader 4.1 even with DirectX 10 August revision. So not sure if this Feb 2010 one is gonna make much difference we shall see. Should I try to update my ATI/AMD GPU drivers aswell?
Reply




Users browsing this thread: 1 Guest(s)