Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy XII black textures and FMV black frames
#1
Hi there guys!
I'm playing Final Fantasy XII (12) on the latest pcsx2 release.
It's pretty perfect, beside two little annoying things.

One is that sometimes, in the cutscenes only (not the FMVs), I have some corrupted textures, they are simply black..

[Image: BJEFaFY.jpg]
[Image: nWzrf7g.jpg]

I tryied many option in the emulator config, but the only way to get rid of it seems to select the native resolution of the game... that is awful.

Have you got some advise to solve the problem?

The second problem is that here and there I have black frames during the FMV playback..
I tried both the manual game fix and the F9 trick for the software rendering during the playback..
But PCSX2 crashes either way.

How could I get rid of those annoying black frames?

Here is my emulator config:

Everything is default, besides the values in the images

[Image: 5hDYf9r.jpg]
[Image: EDlvBVy.jpg]
[Image: aIY9Mfi.jpg]
[Image: 76PjvJI.jpg]

I got an i7 3770K overclocked
16GB ram
256GB SSD
Geforce 680 4GBram
Win 7 x64

Thank you very much for your kind replies! Laugh
Reply

Sponsored links

#2
(01-04-2014, 06:12 PM)Geralt Of Rivia Wrote: *snip*
You're posting on an English forum. Please have your screenshots in English for easier support. Luckily for you I have enough familiarity with other languages (conjugates) that I can figure out a few things myself.

The emulator and game are fine. It is an issue on your end, so you need to do a few things. If you aren't sure how to do these things, please use an internet search to find the answers.

1 - Post your PCSX2 version. If you're asking for tech help, then this is very important information. Your PCSX2 version should be in the title bar window after you run PCSX2.

2 - Update DirectX. You should download the 'web updater' from the official Microsoft website. You also want to search on that same website for DirectX v9.0c latest version. Download and install that (using offline installer).

3 - Find out what video card (GPU) you have and get the updated drivers for it. The two main video cards are Nvidia and AMD/ATI. If yours is different then it is likely onboard/integrated graphics and you'll have many issues like this for PCSX2 and other games.

4 - You should try using the official PCSX2 v1.0 from this website. If you are already using that, you can try the SVN version (link is on the main homepage for PCSX2 on the upper right side). From what I can see, you may be using an older version of PCSX2.

5 - Use 'Scaling' instead of Custom Resolution. Turn off Alpha hack and Turn off the 'Enable Hardware Hacks' as well. If the issue still occurs after doing all this, also turn off all the SpeedHacks and try it again.
Reply
#3
Thanks for your kind reply Smile

(01-04-2014, 07:57 PM)darkwraith007 Wrote: You're posting on an English forum. Please have your screenshots in English for easier support

Sorry for that, I thought that as you said many people on this forum is familiar with the emulator, so it wouldn't be difficult to recognize the settings even if in another language.
(01-04-2014, 07:57 PM)darkwraith007 Wrote: The emulator and game are fine. It is an issue on your end, so you need to do a few things. If you aren't sure how to do these things, please use an internet search to find the answers.

1 - Post your PCSX2 version. If you're asking for tech help, then this is very important information. Your PCSX2 version should be in the title bar window after you run PCSX2.

2 - Update DirectX. You should download the 'web updater' from the official Microsoft website. You also want to search on that same website for DirectX v9.0c latest version. Download and install that (using offline installer).

3 - Find out what video card (GPU) you have and get the updated drivers for it. The two main video cards are Nvidia and AMD/ATI. If yours is different then it is likely onboard/integrated graphics and you'll have many issues like this for PCSX2 and other games.

4 - You should try using the official PCSX2 v1.0 from this website. If you are already using that, you can try the SVN version (link is on the main homepage for PCSX2 on the upper right side). From what I can see, you may be using an older version of PCSX2.

5 - Use 'Scaling' instead of Custom Resolution. Turn off Alpha hack and Turn off the 'Enable Hardware Hacks' as well. If the issue still occurs after doing all this, also turn off all the SpeedHacks and try it again.

1 - the pcsx2 version is 1.1.0.5766

2 - DirectX are updated. I just regenerated the PC and installed the directx libraries using web installer

3 - as you can see in the GSdx screenshot and at the end of my first post, I've an nvidia gtx 680, with driver updated 3 days ago

4 - I'm using the official pcsx2 from the website. I don't know if I'm using an older SVN version.. as far as I know, since I'm using the last version of the emulator, it should be up to date, shouldn't it?
Is there an SVN version you would recommend?

5 - I was using custom resolution just to match my monitor resolution... which 'scaling' option is better to reach the more possible my 2560x1440 monitor resolution? 2x/3x/4x/5x/6x? I've seen the PAL resolution for the game is (as the emulator says) 448x512 ..strange resolution indeed..

I've already tried turning off all hacks (alpha, hardware hacks, speed hacks), but the problem of black textures remains... alpha seems necessary to me, if not I've got the character edges with some sort of offset, like a bad post processed bloom..

Do you have clues about the black frames that sometimes occur during video playback?

Thank you very much.. I'll be doing other tests.. Smile


::::EDIT 1:::: using scaling native resolution x5, the black textures problem si gone!! Laugh
Thanks you for your advice! Smile
What if I choose x6? The graphic quality should improve more?

Ok, now there is only the black frames problem during the FMV palyback Smile

::::EDIT 2::::
ok, now the software rendering for the FMV works, and the black frames are gone too from the playback. Laugh
I think I'm gonna activate the manual fix in order to automatically switch between hardware and sostware rendering only when FMV are playing. Let's see if it works. Smile

So, just a last question.. is there a way to have brighter FMV sequences? I don't know why, but they are darker compared to the rest of the game Smile
Thnak you very much! Laugh
Reply
#4
See in GSdx window, the number at the start? xxx*yyy? That's games normal resolution. Setting yX number is multiplying those. So, if you set 6x on 512x448 you are setting 3072x2688.

There is not much point in setting a number above your monitor's resolution. There is a small SSAA, but it will look better to set e.g 3x and 2 or 4x MSAA in HW hacks. MSAA can cause glitches though.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
I've edited twice my previous post Smile

(01-04-2014, 09:59 PM)Blyss Sarania Wrote: See in GSdx window, the number at the start? xxx*yyy? That's games normal resolution. Setting yX number is multiplying those. So, if you set 6x on 512x448 you are setting 3072x2688.

There is not much point in setting a number above your monitor's resolution. There is a small SSAA, but it will look better to set e.g 3x and 2 or 4x MSAA in HW hacks. MSAA can cause glitches though.

So it's better 5x.. that should be 2560x2240... at least I have the 2560 as an exact number.. Smile
thanks for the SSAA advice, but with a 5x resolution I don't need it Smile
Reply
#6
(01-04-2014, 10:04 PM)Geralt Of Rivia Wrote: I've edited twice my previous post Smile

So it's better 5x.. that should be 2560x2240... at least I have the 2560 as an exact number.. Smile
thanks for the SSAA advice, but with a 5x resolution I don't need it Smile

I'd like to know if your issue is solved.
If so, then what solution worked for you?
Please reply here or PM me so I can edit my post with the info. Thanks!

Using custom resolutions almost always guarantees bugs, glitches, and graphical issues. I know of one game that requires a very specific custom resolution in order to avoid major graphical issues that render it unplayable, but there's part of the bottom cut off as a result of that tweak.

It is almost always a better idea to just use the X multiplier scaling like 2x-6x instead of custom resolutions.
Reply
#7
(01-13-2014, 02:21 AM)darkwraith007 Wrote: I'd like to know if your issue is solved.

He said it was in an earlier post/edit Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)