Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy XII on HP Pavilion dv7
#1
Hi guys!

First of all, thank you for such a great job, I love the emulator!

To the point... (^_^);


I'm using PCSX2 version 1.0.0, on a HP Pavilion dv7 laptop (yeah I know, laptops are not advised /cry), but anyhow I'm still in the "ok" section with an i5 Intel Core CPU, 4GB RAM, 64-bit OS on Windows 7, and a ATI Mobility Radeon HD 5650.

Switching to XP compatibility mode even got rid of random crashes so Okami plays beautifully, just on default emulator settings.

Now my current problem:

I got hold of Final Fantasy XII (my favourite) and I have some minor but getting-annoying troubles. The cgs play good, sound and video at normal speed, but once the main title screen or the memory card loading screen appear, the sound goes too fast and it sounds like I'm in a Smurf movie! Then once I load and actually play, the speed kind of varies, and the voices too. For example, starting a new game with Reks, when you can control him and they tell you to walk and turn the camera, it's all fine, but as soon as I start a fight with a soldier, it gets stuttered. And when the stage boss (Remora) appears, it all slows down.

I've played with all settings, plugin settings, emulation, speed hacks, tried different combos, but there is something I am missing surely.

Now I've turned everything back to default, I can't figure it out.
Can someone please enlighten me?

m(_ _)m
Reply

Sponsored links

#2
(04-25-2013, 10:47 PM)Bebekara Wrote: Hi guys!

First of all, thank you for such a great job, I love the emulator!

To the point... (^_^);


I'm using PCSX2 version 1.0.0, on a HP Pavilion dv7 laptop (yeah I know, laptops are not advised /cry), but anyhow I'm still in the "ok" section with an i5 Intel Core CPU, 4GB RAM, 64-bit OS on Windows 7, and a ATI Mobility Radeon HD 5650.

Switching to XP compatibility mode even got rid of random crashes so Okami plays beautifully, just on default emulator settings.

Now my current problem:

I got hold of Final Fantasy XII (my favourite) and I have some minor but getting-annoying troubles. The cgs play good, sound and video at normal speed, but once the main title screen or the memory card loading screen appear, the sound goes too fast and it sounds like I'm in a Smurf movie! Then once I load and actually play, the speed kind of varies, and the voices too. For example, starting a new game with Reks, when you can control him and they tell you to walk and turn the camera, it's all fine, but as soon as I start a fight with a soldier, it gets stuttered. And when the stage boss (Remora) appears, it all slows down.

I've played with all settings, plugin settings, emulation, speed hacks, tried different combos, but there is something I am missing surely.

Now I've turned everything back to default, I can't figure it out.
Can someone please enlighten me?

m(_ _)m
At some point you pressed F4 what disabled the framelimiter... and the machine is actually able to get that part well over the standard speed Smile

So, press F4 again and tell us the result.

Edit: I told myself not bringing that thing of shortcut actually changing the config in persistent way, but can't avoid. That's a major issue and cause of threads like that, devs... make F4 not changing the ini-GUI option, so that at least restarting the emulator should make things normal again.
Imagination is where we are truly real
Reply
#3
Nope, that didn't happen because I have to press the "F" button on my kb to be actually able to press any F4 or F3 buttons. But I did check in the config if that option was checked and it's not. So I do have the limiter on, but I noticed today, when I was in Rabanastre, framerate seems a bit messed, it went up to 100 and it was the Smurf effect, Vaan even moved a lot faster and the music was too fast too. Then it went down to 30 FPS and all was too slooooooow.
Reply
#4
Fn or F key, so you have a laptop? Smile but have you tried pressing Tab perhaps? that'll put the emulator in Turbo mode.
Reply
#5
Yes I do have a laptop, and no I didn't even tab /cry, but let me just run it again in case, just to make sure.
Reply
#6
Ok so what happens is:

Inside town my framerate goes down from normal 50 to 25 (sloooooooow Vaan), outside in the field it's ok, steady 50, and menus/load its up to 90 (Smurf).
Turbo is disabled, limiter is on (base frame adjust 100%, slow 50%, turbo 100%).
Tried also diferent video plugins which come with the emulator, but no difference.
So it is framerate, but how can I make it so it plays always at 50? Why does it go down to 25? and why up to 90+? It should play constant 50 for PAL version...
Reply
#7
When it goes down to 25, either your cpu or gpu are struggling. If its gpu you can try lowering the resolution. Otherwise try playing with speedhacks.

As for going up to 90+, that will only happen if frame limitig iis off or if you use turbo mode. Make sure disable frame limit is not ticked, or hit f4 in game. Then make sure you arent accidentally activating turbo mode (which is tab iirc)
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#8
Ok I will try resolution!
Thank you all <3
Will post if it did or not make a difference Smile
Reply
#9
Lowered the resolution from 1024/1024 to 500/500 hehe.
Nothing, still goes down to 20ish sometimes. At least it seems to not go up anymore, so no more helium effect!
Reply
#10
If lowering the resolution didnt change anything, then your cpu is struggling. Not much you can do there other than try speedhacks.

Although from what I can find about your laptop, seems wierd that its not able to get full speed unless yoj have no hacks on.

Try all recommended ones and mtvu. Also change your laptops power options to high performance to avoid throttling.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply




Users browsing this thread: 1 Guest(s)