Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final fantasy X pal at 60 fps possible?
#1
Hello all,

Seeing how I recently got myself a new pc, I had to check out the latest pcsx2 version, and I finally have a pc that's good enough Smile

So now I've been trying to get my dream working: my favorite ps2 game final fantasy X running full HD at 60 fps instead of the 50 which I've been stuck with since the game came out.

Now, I got the full HD and 60 fps thing set up very nicely, which is awesome btw Smile
BUT, the first cgi I encountered (blitzball and all that) had it's music screwed up :/ (not noise or anything, just what you'd expect, it chops out 1/5th or so from several pieces, still sounds nice, just messed up XD)

So yeah, I guess just putting the base PAL fps to 60 didn't work out as smoothly as I'd hoped '^^

So that's basically my question, is there any way to get the game running at it's best speed (60 fps) while still having everything else (music, sounds, video's) work properly AND still have the extra's that my pal version has? (Can't have an ultimate ff X experience without the dark aeons and penance Laugh, not to mention I don't own a ntsc copy '^^)

Or would I have to make save-states at the start of each cgi, turn fps to 50, watch it, turn fps back to 60? And finally, would doing this mess up any other sounds and music? From what I could tell the other sounds and voices worked normally at 60fps (but I stopped at the messed up first cgi).
Reply

Sponsored links

#2
(10-18-2010, 02:27 AM)kenshee Wrote: Hello all,

Seeing how I recently got myself a new pc, I had to check out the latest pcsx2 version, and I finally have a pc that's good enough Smile

So now I've been trying to get my dream working: my favorite ps2 game final fantasy X running full HD at 60 fps instead of the 50 which I've been stuck with since the game came out.

Now, I got the full HD and 60 fps thing set up very nicely, which is awesome btw Smile
BUT, the first cgi I encountered (blitzball and all that) had it's music screwed up :/ (not noise or anything, just what you'd expect, it chops out 1/5th or so from several pieces, still sounds nice, just messed up XD)

So yeah, I guess just putting the base PAL fps to 60 didn't work out as smoothly as I'd hoped '^^

So that's basically my question, is there any way to get the game running at it's best speed (60 fps) while still having everything else (music, sounds, video's) work properly AND still have the extra's that my pal version has? (Can't have an ultimate ff X experience without the dark aeons and penance Laugh, not to mention I don't own a ntsc copy '^^)

Or would I have to make save-states at the start of each cgi, turn fps to 50, watch it, turn fps back to 60? And finally, would doing this mess up any other sounds and music? From what I could tell the other sounds and voices worked normally at 60fps (but I stopped at the messed up first cgi).

The PAL version is designed to run at 50fps. There's no way you're going to run it at 60 without these kind of issues.

You may not have realised it but everything will run at 6/5ths the speed it's supposed to as the game's timing is hard coded in sync with the screen refresh rate (framerate in this case), not like in PC games where the speed and framerate are independent.

If you want an NTSC copy with these extras look for the Japanese Final Fantasy X International. It has english text and audio, but runs at the 60fps you desire. It's not a rare game as far as I am aware so you should be able to pick it up on eBay.
Specs in Profile
Reply
#3
Oh, so it has text in English as well? Wow thanks, it's sort of shameful I didn't know that XD

I guess I just assumed it was like the kingdom hearts final mixes.

I should be able to get it, a friend of mine imports a lot of stuff ^^
Reply
#4
(10-18-2010, 02:41 AM)kenshee Wrote: Oh, so it has text in English as well? Wow thanks, it's sort of shameful I didn't know that XD

I guess I just assumed it was like the kingdom hearts final mixes.

I should be able to get it, a friend of mine imports a lot of stuff ^^

Yeah, when you start a new game, you will be asked a series of questions just like in the PAL version. The first is to choose the Regular or Advanced Sphere Grid, the second is to confirm your choice, and the third is to choose Japanese or English text. I can make a short video showing you if you'd like.
Specs in Profile
Reply
#5
You could try going to "Config > Emulation Settings > GS" and change the PAL framerate to the same as NTSC, if the PAL game was just a bad conversion of the NTSC one it could work Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
Care to point me to directions to up the graphics? Im using latest version/my pc is more than capable. Thanks in advance.
Reply
#7
(10-18-2010, 03:39 AM)Lunar4 Wrote: Care to point me to directions to up the graphics? Im using latest version/my pc is more than capable. Thanks in advance.
First, make sure you're using GSdx, and have chosen the best version that your processor supports. Choose Direct3D10 or Direct3D11 (Hardware), which one you see will depend on which graphics card you have.

Set Interlacing to None because as far as I am aware neither the PAL nor NTSC versions of the game suffer from any Interlacing artifacts, but for other games you might need to change this.

Now set the D3D internal res to your monitor's native resolution. If you're using 4:3 or 16:9 modes instead of Fit to Screen then work out the 4:3 or 16:9 equivalent of your resolution. Assuming you have a 16:10 monitor, to get your width for 4:3 divide the height by 3 then multiply it by 4 and to get your height for 16:9 divide the width by 16 then multiply it by 9. I would recommend the 4:3 mode for FFX and X-2 but the 16:9 mode for XII.

Leave Texture filtering and Allow 8-bit textures as they are. The default settings are the most compatible.

For further improvement you'll need to change the line "allowHacks=0" to "allowHacks=1" in your GSdx.ini file. Then you will have more options in the GSdx window. Hardware Anti-Aliasing will smooth out jagged edges on 3D objects and is normally set in powers of 2, e.g. 2,4,8,16.

Finally, if you dislike the outline effect around 3d objects in battles, you can set SkipDraw to 1 to get rid of this. Personally, I don't mind it as it gives a Depth of Field effect.

Specs in Profile
Reply




Users browsing this thread: 1 Guest(s)