Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Flickering & vanishing Textures in FFX/-2 and Kingdom Hearts
first of all, let me say thanks for your fantastic work on the emulator and the plugins! It hasn't been long ago when I thought that emulating the PS2 is a no go, but the past few weeks have shown me otherwise. I was able to play Final Fantasy X with a few minor glitches, and that was quite an experience.

One of those glitches were vanishing textures. Sometimes, textures would be visible from a certain angle and then vanish if I got closer or if I moved my character. This was rather sporadic, so I just ignored it.

Unfortunately, in FFX-2, the very texture that makes this problem is the dress of the main character, which is much more distracting. I am running around with a flickering mess:

[img][Image: screenshot6ylh.jpg][/img]

In Kingdom Hearts, the problem is also more disturbing than in FFX because the number of those flickering textures is higher, there is almost always something that is flickering in some way, here it is the carpet:

[img][Image: screenshot3p.jpg][/img]

I am running XP with SP3, Q9550, Geforce 275, 4 gigs of ram. Video drivers and DirectX are up to date.

This problem occurs with the latest beta as well as with 0.9.6, with both gsdx and ZeroGS. I tried all of the settings in both plugins, nothing works. Switching to software mode in gsdx helps with the textures in Kingdom Hearts, but not with the ones in FFX-2. It occurs with speed hacks and without. Changes in the advanced settings menu didn't make any difference as well.

I also tried changing the display driver settings in the nvidia controls. No difference there as well.

If anyone has any clue, I'd be grateful for suggestions.

But anyway, thanks again for your hard work.
Many greetings

Sponsored links

try enabling logarithmic Z in gsdx, it should fix some glitch but not all Wink
and remenber to download the lastest revision
The FFX textures problem is on PCSX2 which never got fixed if I recall correctly, if you disable VU1rec it should be gone but the game will be too slow anyway so I guess you'll just have to live with it :P
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Thanks for your replies! Actually, logarhytmic Z is already activated. Already fixed some more flickering textures in FFX with that. And thanks for the link to the beta archive! Didn't know about this. I thought that using the latest public beta on the download page is using the very latest version Wink Unfortunately, the brand new version doesn't make any difference. Oh and thanks for pointing at the VU1rec switch! It actually makes the flickering in FFX-2 disappear! But you were right. Slow isn't even the right word. It is a progression of still pictures. Absolutely unplayable. So are you saying this is not a plugin bug but a problem with the emulator as such? Is there any chance it's getting fixed or did they just skip it?
Many greetings
for now, there's nothing to fix it (or at least I don't know howTongue) but I think that is better to get good speed and minor graphics gliches that get very low speed for fix gliches.
thanks for your replies.
Many greetings
with the new revisions 1648, 1651, and 1652 FFX-2 run slow(at least for meTongue), is better to use the revsion 1647, with this should run fast and whitout skipping.
The only way to make the z-fighting (see KH carpet) problems dissapear is using dx10. You'd need vista/7 for that.

Users browsing this thread: 1 Guest(s)