Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Force feedback latency
#1
Hi people. I have Saitek PS2700 Rumble Pad for Pc with usb. With lilypad test works without latency but in games one second later rumble comes. I also connected a ps controller with ps to pc adapter, there's no such problem. How can I resolve this?
Reply

Sponsored links

#2
Sounds like a bad pad driver. Do you have a driver disk?
Reply
#3
Yes I downloaded it from Saitek's web site today.
Reply
#4
This same thing has been happening to me since PCSX2 0.9.7.
I use a Dualshock 2 and the driver is called "SPEED-LINK DUAL SHOCK ADAPTER". Vibration starts late, it's too strong and it lasts too much time.
Vibration works perfectly in other emulators and PC games as well. I'll try it this evening with the latest SVN to confirm if the problem persists.
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
Reply
#5
Is it work fine with pc games ?
Or test it in devices & printers from start menu
click on properties of u'r gamepad in devices & printers & in vibration tab move left analog stick left right
check if it works fine there !!
Reply
#6
Not sure about in general, but I can confirm with both 1.0 and 1.1.0 that vibration works as it should with a PS3 controller via MotionInJoy at least.

(quick edit) I believe that there can be vibration errors like it lasting too long if a game isn't running full speed. I seem to remember having an issue like that with an older PC of mine, but don't still have it around to test.
[Image: 2748844.png]
Reply
#7
I have tested my saitek on pcsx1 emulated game, it worked perfect.

Also about pcsx2, I agree with masterotaku "it's too strong and it lasts too much time."
Reply
#8
(07-04-2013, 03:03 PM)seamoon Wrote: I have tested my saitek on pcsx1 emulated game, it worked perfect.

Also about pcsx2, I agree with masterotaku "it's too strong and it lasts too much time."

i have no problem with rumble
it working perfectly Smile
Reply
#9
(07-04-2013, 03:10 PM)Preet Wrote: i have no problem with rumble
it working perfectly Smile

On Pcsx2? How do you do that?
Reply
#10
(07-04-2013, 03:23 PM)seamoon Wrote: On Pcsx2? How do you do that?

nothing to do just on default options
clear all buttons & remap them
btw u'r big motor is on constant & small motor on square wave ?
i'm using official version r5350 !!
Reply




Users browsing this thread: 1 Guest(s)