Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Forcing PCSX2 to english?
#1
Hi! I just set up the emulator with two controllers without problems, except one.
I have my keyboard language set as finnish, as it has to, in Windows.
I, however, did change the language to english in the very first window the first time i launched the setup. In the last window of the setup, it seemed to be forgotten since there was finnish instead of english in the "finish"-button. The actual client was in finnish too. I'd rather use PCSX2 in english than in finnish. I've always liked things that way.
Please note that Windows itself is in english.
Reply

Sponsored links

#2
In the main UI -> MISC -> Change Language
Reply
#3
(12-30-2014, 01:25 AM)willkuer Wrote: In the main UI -> MISC -> Change Language

This is exactly the reason why i made this thread. Changing the language through the application itself has no effect whatsoever. I have done this multiple times.
[EDIT] Apparently "Import" reverts the change. Sorry for the inconvenience.
Reply
#4
(12-30-2014, 10:25 AM)tinkkiski Wrote: This is exactly the reason why i made this thread. Changing the language through the application itself has no effect whatsoever. I have done this multiple times.
[EDIT] Apparently "Import" reverts the change. Sorry for the inconvenience.
could you provide a screenshot of it.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
You are asked during the wizard if you want to import the old settings. Obviously you can not change the language if you import all settings. This is actually really a bug since running the wizard is the only real UI-possibility to reset the language. Somebody seemed to be to lazy to program a new UI-element to support language changes.

The only way to change the language is therefore to change the ini or to reset the whole emulator.

But probably this option is used quite rare. Maybe one should just disable/hide the menu entry. if somebody wants to change language he/she either can delete the ini-folder or look for the correct entry.
Reply
#6
(12-30-2014, 01:19 PM)ssakash Wrote: could you provide a screenshot of it.

Simply put: changing the language and importing your previous settings don't work together. I reckon a screenshot is obsolete here.
Reply
#7
(12-30-2014, 03:51 PM)tinkkiski Wrote: Simply put: changing the language and importing your previous settings don't work together. I reckon a screenshot is obsolete here.
what version of pcsx2 does this problem occur in ? and, just for a reference please post the screenshot of the configuration part in finnish.
edit: nevermind, looks like willuker found out the problem. refer to his reply to fix it.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
Should be fixed now - https://github.com/PCSX2/pcsx2/commit/c4bd50
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#9
(12-30-2014, 07:42 PM)avih Wrote: Should be fixed now - https://github.com/PCSX2/pcsx2/commit/c4bd50

muahahaha... sometimes I am a bit impressed by your productivity, Two open problems, two posts, two revisions. When I lead a multi-billion dollar company I will consider hiring you.


And good trick to make a very simple non-localized dialog to solve the problem Tongue
Reply




Users browsing this thread: 1 Guest(s)