Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fps high emulation slow (search showed nothing)
#1
I attempted several searches of the site everything regarding slow emulation that I could find was reffering to the fps. When starting any game (either by fast boot or anything) the fps is around 50-60 depending on the game. Not spiky or anything. However the game seems to be running at 20% speed. I don't know if that makes any sense to anyone here but the problem is not fps.

I tried several of the settings. I attempted to use the standard first and nothing I was able to change, fixed this. Im using 9.7

I have an amd 2.1 turion dual core processor 4 gigs of ram and an ati graphics card (supposadly) has 256 mb of vram. It is a laptop however.

I stopped modifying everything after learning I could ruin the game. I am booting it straight of the disk.
Reply

Sponsored links

#2
Full PC specs? PCSX2 settings? Plugin settings?

If you get 60 fps and the game seems slow is usually an indication that you used too many speedhacks. If what you mean however is that it starts at 60fps then it slows down that's normal since usually there's not much rendering going on when games boot and it's faster then.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(09-05-2010, 05:53 AM)Shadow Lady Wrote: Full PC specs? PCSX2 settings? Plugin settings?

If you get 60 fps and the game seems slow is usually an indication that you used too many speedhacks. If what you mean however is that it starts at 60fps then it slows down that's normal since usually there's not much rendering going on when games boot and it's faster then.

Windows 7.

No speed hacks even though later I tried no changes.

The fps doesn't drop at all. No drops. none.

the little fps reader no hacks or hacks. The FPS is fine. its the game itself.

You know how in 300 they edited the movie so that it went into slow motion at points? And you know how it doesnt seem choppy at all? Yeah kind of like that. The game is running at 20% or so same with the audio. The fps stays at a solid 50-60.

The fps doesn't slow down the events in game do.

(yes I know speed hacks give false fps readings.) This is with and without speed hacks.

GS = GSdx 3068 (msvc 15.00, sse2) 0.1.16 {gsdx-sse2-r3068
Pad Lilypad svn (r2930) 0.10.0 [lilypad-r2930
spu2-x r3117 1.4.0 [spu2-x-r3117
cdvd cdvdGigaherz (r3006) 0.8.0 [cdvdGigaherz]
fw fwnull driver 0.6.0 [FWnull]
DEV9null Driver 0.5.0 [DEV9null]

windows 7 64 bit btw.
Reply
#4
Try a different game?
You might have frameskipping enabled, or you have to set to draw frames where the PC cannot render (it'll draw w.e # of frames you're missing). Say... your PC actually renders at 20fps, it'll draw 40 more frames just so it "appears" to be 60fps.
CPU: i7 930 @ 2.8GHz(Everyday)/3.6GHz(Gaming)/4.0GHz(Encoding)
GPU: Geforce GTX 480 @ 850MHz/1001MHz
Motherboard: ASUS P6X58D-E
RAM: 2x3 6GB OCZ @ 1527MHz 8-8-8-24
Reply
#5
(09-05-2010, 06:43 AM)frosty5689 Wrote: Try a different game?
You might have frameskipping enabled, or you have to set to draw frames where the PC cannot render (it'll draw w.e # of frames you're missing). Say... your PC actually renders at 20fps, it'll draw 40 more frames just so it "appears" to be 60fps.


Yeah frame skipping is disabled.

Sad

hey I fixed something that saw a huge improvement.


I disabled use synchronized mtgs.

My framerate is (now) dropping. but its at 27 fps. Its possible I was wrong and misreading the fps? or that messing around fixed something?

Any ideas what else I could do to speed this up a bit more. Whatever unchecking use synchronized mtgs did it helped. Anything else in the options along those lines will likely be a big help as well.

(also will burning it into an iso be a help?)


its not a stutter it just seems really slow Sad

Ive tried three different games. (one of the three also had lines going through like bars vertical 3 of them.) other two work ok other than being slow.

One was ace combat 5 (this is the one with the weird lines)

other one was dot hack //infection
and xenosaga

They just run sloooow.

Should I try to enable frame skipping?

SO I disabled an option called Synchronize mtgs and my framerate went up. (apparently I was misreading my framerate or even though my framerate went down it got faster)

Don't know which it was and I don't know if I should feel stupid or if theres something else going on here.

Anyways anything else I can do other than disabling the mtgs sync that might be along those lines?
Reply
#6
Perhaps burning the disk onto the hardrive as an iso might speed it up?

I don't know.

how would you do that?
Reply
#7
Let's see... Try using native resolution in GSdx's internal resolution setting, that will fix the weird black bars for Ace Combat and speed up your games a lot. Other than that I would suggest enabling speed hacks to get more fps.
CPU: i7 930 @ 2.8GHz(Everyday)/3.6GHz(Gaming)/4.0GHz(Encoding)
GPU: Geforce GTX 480 @ 850MHz/1001MHz
Motherboard: ASUS P6X58D-E
RAM: 2x3 6GB OCZ @ 1527MHz 8-8-8-24
Reply
#8
(09-05-2010, 08:16 AM)frosty5689 Wrote: Let's see... Try using native resolution in GSdx's internal resolution setting, that will fix the weird black bars for Ace Combat and speed up your games a lot. Other than that I would suggest enabling speed hacks to get more fps.

How do you change the native resolution in 9.7?

found it. It diddnt do much Sad
Reply
#9
Ok so I was stupid the whole time apparently.

The game seems at least at parts to work just fine. Seems the problem with the fps is only in the fmvs. (of which there are quite a few) Good god I hope this isnt a problem in xenosaga or it will be unplayable. ( 8 hours of cinimatics in that game)

Anyways looks like the issue is purely fmv side. Does that help in the way I should have anything set up?
Reply
#10
Leave 'Synchronized Multithreaded Graphics' (Synchronized MTGS) unchecked. Now try using speedhacks. You should get a lot better results. I lose about 2/3 of my speed if I use synchronized MTGS... which is one of the reasons why it's for debugging purposes.

VU cycle stealing makes a huge difference in floating-point heavy games and EE cycle rate reduction helps a lot if your EE usage is below 80-90% most of the time.

In the EE and VU rec options for rounding and clamping you can use nearest and none or chop/zero and normal.
CPU: Pentium D 'Presler' 915 2.8 ghz 2x2MB L2 @ 3.5 ghz
GPU: eVGA [Nvidia] 8600GT 256MB SSC DDR3
Tested: FFX, FFX-2, FFXII, MGS3, KH, KH2, The Hobbit NTSC
PCSX2 FTW! Biggrin
Reply




Users browsing this thread: 1 Guest(s)