Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame Limiter not working when using D3D11 Hardware rendering ?
#1
Using upgrade to latest svn 1.3.1 1008 version , love those widescreen patch collection
so played for awhile and found out F4 not working anymore with d3d11 hardware rendering?
and getting fine again when i switch to d3d9 or ogl hw, maybe there's little mistyping in code?
Reply

Sponsored links

#2
None of that code has changed and is universal with all renderers, so i don't know why that doesn't work.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(08-20-2015, 10:11 PM)refraction Wrote: None of that code has changed and is universal with all renderers, so i don't know why that doesn't work.

there is bug in framelimiter F4 there times hiting F4 works for toggling limiter and other times where it does not work. I think i happens when switching renders/changing setting in GSDX been there for while, I reported it once or twice few months back i even opend i git issue about once i think? i know i once made post about it

Going in the menu and manual selecting to enable/disable limiter works fine though. f4 button is what seem to get bugged and stuck, the GSDX window shows it get toggled but it random dont work.
Reply
#4
Weird, I've never managed to get it to go wrong..
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
(08-21-2015, 12:53 AM)refraction Wrote: Weird, I've never managed to get it to go wrong..

I been see it happen alot last few months most cause I random testing DX11 and OpenGL speeds in games, and turn off Limiter.

Some time toggle with F4 works other times GSDX windows say normal and then none, but it still enabled some times the GSDX window does not update at all when toggling F4. Usully when this happen I have to go in to menu manaul to toggle it, and it will work, but to get F4 to work again I need to shut down PCSX2.

IF this make sense to you anyway, cause I not that great at explain things.

Honestly I Think i have magic gnomes in my PC some game Like Xenosaga Run way better then should, blyss and I never fiqure out why either. but he seen proof that it does to
Reply
#6
Yes,I notest that too but I wasn't able to find a reproducible method.
It happens randomly when I'm switching renderers and pressing F4(to see which one runs faster).
I usually fix it(when F4 stop working)by pressing Tab and F4 in some order.
Reply
#7
I can confirm this.

It seems to happen to me more if I hit TAB and THEN F4 while already at turbo.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
(08-21-2015, 06:29 AM)Blyss Sarania Wrote: I can confirm this.

It seems to happen to me more if I hit TAB and THEN F4 while already at turbo.

Why would you want to frame limit and turbo?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
(08-21-2015, 10:19 AM)refraction Wrote: Why would you want to frame limit and turbo?

It's the other way around. Tongue2

PS: either way, I tried all possible combinations and no luck in reproducing this issue. Sad
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#10
oh i see Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)