Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame Limiting Issues
#1
I tried using the search function and didn't come up with anything relevant, so forgive me if I'm asking an old question.

Whenever I play any game, I've been getting minor slowdowns. Usually nothing so bad it makes the game unplayable, and I had just figured it was the norm. Usually a drop to about 90%, 80% at the worst on most games. I just chalked it up to not having a good enough computer for emulation. Until yesterday, when I was having weird slowdowns with FFXII, and I tried putting the frame limit to normal (render all as fast as possible). This caused a massive speedup, making the game play at an average of 80fps, even with 4x resolution scaling.

So, I went back and tested it on the other games I had been playing, and it seemed to be universally true. Just by the act of limiting frames at 60/auto, I get an artificial slowdown to about 50-55fps, even though my computer is more than capable of handling rates over 60fps. Forcing frame skipping doesn't seem to do anything at all, I'm not even sure if it works. Is there any way to stabalize this so that I can just get a constant 60fps instead of having to choose between slow-mo and fast-forward? The speedup is nice for some slower JRPG battles, but it messes up the music and voices .

And for completions sake, my computer specs are
Phenom II x4 @2.8ghz
ATI Radeon HD4870
4GB DDR2 RAM
Windows 7 32-bit

Thanks in advance for any help.
Reply

Sponsored links

#2
This is usually caused by enabling Vsync in either GSdx's settings or in the graphic card's control panel. Check if it is enabled.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(03-09-2010, 03:51 AM)Shadow Lady Wrote: This is usually caused by enabling Vsync in either GSdx's settings or in the graphic card's control panel. Check if it is enabled.

Derp, that fixed it. 6 months of random slowdowns I could've avoided by unchecking a tick mark in a settings box. Thanks a ton, and sorry for my stupidity.
Reply
#4
i have frame limitting issues too, only a lil bit different...if i go to cpu and check vu skip and frame limit to auto i get 40% speed. BUT if i put instead of 0(auto) another nr such as 60 or 70, it plays full speed but with some graphical errors. this happens for all games i have. i use 0.9.6 version.
My pc specs:
AMD 64 x2 4600+ 2.4ghz
nvidia 6150se
3gb ram
windows xp x86
anyone has had this problem yet? cuz i used search and couldn't find anything :/
[Image: signaturel.jpg]
Reply




Users browsing this thread: 1 Guest(s)