Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame Rate Below 40 FPS
#1
I have a Lenovo y510p laptop and I'm trying to play Shadow of the Colossus. The game is running very very slow and it is really setting me off. Hardware is definitely not a problem because I'm running an intel i7 4700MQ, 12 gigs of RAM, and 2 NVIDIA 750gt cards. I've played around with the settings of the emulator and with the NVIDIA control panel, only with the result of making it worse. I've set everything back to default. What am I doing wrong?

Thank you so much!
Reply

Sponsored links

#2
That processor has a base clock of 2.4ghz and a boost clock of 3.4ghz (according to Intel's own site.) Some things to know here:

1) Shadow of the Colossus is a very difficult game to run on this emu. The game barely ran on the original PS2. It's hard on both the CPU and the GPU on PCSX2.

2) Go to Speedhacks in the PCSX2 emu settings menu, and set VU Cycle Stealing to 2. This greatly increases the playability of the game.

3) Make sure your processor is actually operating at the Turbo clock whilst this game is running, since 2.4ghz isn't enough. Plug the laptop in and make sure the Power Plan in Windows is set to Performance to ensure minimal chance of throttling.
Reply
#3
Thanks so much! It's so much better. I greatly appreciate your help!
Reply




Users browsing this thread: 1 Guest(s)