Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame Skipping for Interlaced frames issue
I'm trying to use Frame Skip with default values (draw=0, skip=0) when PCSX2 displays interlaced frames and sometimes this leads to:
- black screen. nothing visible.
- you see the correct image only in odd/even lines, while the even/odd lines show some still image not related to what's happening in the game. sometimes even/odd lines are just black making things a bit better to watch.
- you see still image.

things look pretty if i set frame skip to draw=1, skip=2 (or 4, 6...) for example, but this makes the animations look too choppy and such frame skip options are less flexible, because the amount of frames skipped cant be reduced/increased on the fly depending on the gpu load.

so my question is:
is it possible to code auto-frame skipping (draw=0, skip=0) in a way that will take interlaced video output into account and make sure the drawn frames look nice when displayed sequentialy?
for example there could be a checkbox: show only odd/even lines. or idk, make the skip value always as a multiple of 2 Wink

in case it matters, I'm using PCSX2 0.9.7 r2586 (unofficial build)

Sponsored links

Users browsing this thread: 1 Guest(s)