Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame-limiting
#1
Hey guys! I'm an extremely new user to PCSX2 and am having some trouble with the frame rates. I've listed my system specs below just for clarification.

What's happening is when the emulator even starts, the start-up animation is peaking 200+ FPS and running like a "fast forward" motion.
I've used the F4 option to enable frame limiting but this slows down gameplay to roughly 45-49 FPS (making actual gameplay too slow). The F4 option also doesn't affect cutscenes and loading animations.
I've tried using TAB for turbo/boost in conjunction with F4 but this doens't yield any results.

Any thoughts?

My system specs:
i7 920 (oc'd to 4.0ghz)
Radeon HD7970 (3gb)
6gb GSkill 1666
Reply

Sponsored links

#2
F4 till it says "NORMAL" and then it's fine
Reply
#3
The emulation speed changes depending on the game's demand. For example menus tend to be faster than actual gaming (when 3D kicks).

Now, if at the same point the FPS is around 200 without limiting and falls to near 50 when it is active, that means the game is probably PAL (which runs at 50 Hertz, the TV refresh rate). That fluctuation to around 45 FPS should not be happening and we have no actual information to continue the help attempts. Useful information at this point would be telling the game you are trying to play and the emulator's configuration.
Imagination is where we are truly real
Reply
#4
(06-15-2014, 06:11 PM)nosisab Ken Keleh Wrote: The emulation speed changes depending on the game's demand. For example menus tend to be faster than actual gaming (when 3D kicks).

Now, if at the same point the FPS is around 200 without limiting and falls to near 50 when it is active, that means the game is probably PAL (which runs at 50 Hertz, the TV refresh rate). That fluctuation to around 45 FPS should not be happening and we have no actual information to continue the help attempts. Useful information at this point would be telling the game you are trying to play and the emulator's configuration.

So I picked up an NTSC copy of Constantine from a local pawn shop and wanted to test the emulator. I've included three screenshots of my settings. The first photo has the GS tab open in it. (I've linked to the images as they're quite large). Sorry for any little ads on the site I uploaded to, just click the pick and choose "raw image" at the bottom of it to simplify).

http://i62.tinypic.com/xbke41.jpg
http://i59.tinypic.com/25gv22d.jpg
http://i61.tinypic.com/2n07xhi.jpg
Reply
#5
Use Direct3d 11.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#6
Not necessary to look beyond the first picture, you did set the base framerate to 10x the correct speed, besides using draw 4 frames and skipping 4, this is granted to give a jerky motion (although it is disabled there and will not affect things, still is not good idea going above the default 2/2 which is already too much).

The point is you misunderstood those settings, the frame rate adjusts can't in any way increase the maximum speed your machine can reach, to have the correct speed the base frame rate should be kept at 100% although the turbo and slow motion sets may be tweaked, 200% meaning 2x the normal speed, what is reasonable (notice the turbo is FPS limited as well) and 50% means the game will run at half speed.

The second picture shows you changed some defaults as well and not for the better, keep them at the default (bolder lines) and only change them if a specific game ask for it, and even so they are needed almost to pass a specific point in the game and should be returned to defaults afterward.

Is lacking information on the speedhacks which are where you have the best chances to get some speed improvement if necessary, keep in mind the least you change in the emulator's defaults, the better the experience.

Edit: Some few people may prefer all games running slightly faster or slightly slow than the original speed, that's the reason for the base framerate adjust, but that should not go beyond let's say 120% (which means the game running 20% faster) or 80% which means running 20% slower, and those are already too much in some cases and prone to give timings problems, well... The point one shouldn't really mess with those tweaks and surely not that much.
Imagination is where we are truly real
Reply
#7
My apologies, I should have offered the information before on "SPEEDHACKS". The options are disabled/uncheckmarked.

Adjusting the speed values to 100% yields a 65-90 FPS experience, still a bit fast. It has no affect to anything CGI, menu, or loading screen-based.
The emulator itself (when not running a game) in the system browser for the PS2 runs at/over 200fps as well.

While gameplay seems possible now, has anyone else had trouble using XInputs (360 wireless controller)? By default, the right thumb-stick isn't working and the emulator thinks the left thumb-stick is pushed completely left. I've included a snapshot of all controller settings as well.

http://i58.tinypic.com/2uhx3er.jpg
Reply
#8
Uncheck the disable framelimiting box.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#9
(06-16-2014, 01:19 AM)Blyss Sarania Wrote: Uncheck the disable framelimiting box.

Doh!! Thank you!! The FPS issues have been resolved!
Any takers on the controller issue or should I start a new thread?
Reply
#10
Better starting a new thread since the problem is different and the thread's title would be consistent.

Edit: about the framerate speeds, the base framerate should be 100%, the turbo should be 200% (for double speed) and is toggled on/off by the TAB key

The slow motion should be kept at 50% and is toggled on/off by Shift + TAB keys.

As you may know already, F4 toggles the frame limiter altogether on/off.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)