Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame rate dip and then back to normal over and over
#1
Question 
Hi everyone,

First off thank you in advance to any one who takes the time to read this and help out.

With that being said I'm running PCSX2 and I'm using it for Castlevania curse of darkness but honestly I don't think the game matters because I'm experiencing the same symptoms with any game.

What seems to be happening is that the game will run at 60fps and then dip down to about 30 to 35fps and for a few second (normally about 10 or so) and then go back up to the normal frame rate of 60fps.

Now this does seem to happen when the demands of the game are higher leading me to believe that it might be a processing power issue. But to be honest I do run some pretty beefy apps and game on here so its a bit hard to swallow that PS2 EMU would drag where even more physically demanding programs don't.

Anyway in an effort to save time and energy I have included all information that I think will be helpful in trouble shooting this below. If there is anything else I can provide to help get to the bottom of this please let me know.

Thanks once again for taking the time to help, I'm grateful.

John

------------------------------------------------------------------------

EMU Settings:

------------------------------------------------------------------------

[Image: 000.jpg]

[Image: 001.jpg]

[Image: 002.jpg]

[Image: 003.jpg]

[Image: 004.jpg]

[Image: 005.jpg]

------------------------------------------------------------------------

Emulog.txt:

------------------------------------------------------------------------

PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Enterprise Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 16343 MB
CPU name = Intel® Core™ i5 CPU 750 @ 2.67GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 2.665 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3fd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
Binding GS: F:\games\playstation_02\Plugins\gsdx32-sse2-r5350.dll
Binding PAD: F:\games\playstation_02\Plugins\lilypad-r5350.dll
Binding SPU2: F:\games\playstation_02\Plugins\spu2-x-r5350.dll
Binding CDVD: F:\games\playstation_02\Plugins\cdvdGigaherz.dll
Binding USB: F:\games\playstation_02\Plugins\USBnull.dll
Binding FW: F:\games\playstation_02\Plugins\FWnull.dll
Binding DEV9: F:\games\playstation_02\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 539ms)
HotSwapping to new ISO src image!
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: F:\games\playstation_02\roms\Castelvania Curse of Darkness (NTSC) PS2\Castlevania - Curse of Darkness (NTSC) PS2.ISO
Image type = CD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1709664 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\John\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\John\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.68;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_211.68;1) Game CRC = 0x3A446111, EntryPoint = 0x00400008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.68;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.68;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.68;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.68;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_211.68;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(GameDB) Changing VU0/VU1 clamp mode [mode=0]
EE/iR5900-32 Recompiler Reset

------------------------------------------------------------------------

Abbreviated system information:

------------------------------------------------------------------------

[Image: 007.jpg]

[Image: 006.jpg]


Reply

Sponsored links

#2
Try messing with speedhacks. Your cpu isn't that great though.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
use Mtvu ! lowered the resolution !
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#4
from what I see, your CPU might be the problem. What do the EE% & GS% say when getting slowdowns ?
Quote:But to be honest I do run some pretty beefy apps and game on here so its a bit hard to swallow that PS2 EMU would drag where even more physically demanding programs don't.
You have no idea how demanding pcsx2 can be.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(11-03-2014, 04:56 AM)johnyct9760 Wrote: isoFile open ok: F:\games\playstation_02\roms\Castelvania Curse of Darkness (NTSC) PS2\Castlevania - Curse of Darkness (NTSC) PS2.ISO

Are you running the game from an external HDD by any chance?
If the FPS only drop down for a short period of time it may be caused by slow loading times.
Try moving the ISO to your internal HDD and see if it gets better.
Reply
#6
(11-03-2014, 05:16 AM)Brock lessner Wrote: use Mtvu ! lowered the resolution !

I'm not sure what setting your referring to could you please clarify.

Thanks
Reply
#7
config>emulation settings>speedhacks>MTVU
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#8
(11-03-2014, 07:58 AM)jesalvein Wrote: from what I see, your CPU might be the problem. What do the EE% & GS% say when getting slowdowns ?
You have no idea how demanding pcsx2 can be.
a little bit correction

@op~ you have no idea how much bug fixing pcsx2 still need !
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#9
try sw mode +3 threads but, if it just drops for some time , it's mostly a chance of bad rip. did you try playing with the cd if you had the same slowdown for a while without corresponding to the load of textures.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#10
Quote:Loading plugins...
Binding GS: F:\games\playstation_02\Plugins\gsdx32-sse2-r5350.dll
I noticed you're using GSdx SSE2. Run SSE4 instead since your CPU supports it. (You can change this in the Plugins Page: Config>Plugin/Bios Selector>Plugins Tab)

Also enable the MTVU Hack under Speedhacks like Nobbs mentioned.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply




Users browsing this thread: 1 Guest(s)