Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frames problem...
#1
So I was playing around with the plugin's because i was playing through KH and it was doing perfectly (60 frames) and then all of the sudden once I got to halloweentown the frames dropped to like 35. Now my frames will go from 150-200 to around 35 at random times. My Computer Specs are

i7
Geforce GT 650 1GB
8GB Ram

Obviously my comp should be able to run all ps2 games at 60 frames, so I was wondering if you could show me the best configuration for my PC?
Reply

Sponsored links

#2
Are you playing from iso of the game made from imgburn? If you play from disc sometimes slowdowns will occur.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
(06-20-2013, 05:06 AM)SamJustTheDoctor Wrote: (...)
Obviously my comp should be able to run all ps2 games at 60 frames,
(...)
;p That's what I call wishfull thinking. Not only "i7" by itself isn't saying much, but also emulation is quite far from any kind of perfection and sayings like "ALL PS2 games" will not probably ever get at same sentence with "running on pcsx2".



Anyway for your problem, make note that:
- TAB is a key to turn on turbo(basically setting the framelimiter twice as high),
- shift+TAB turns slomo(by default setting it to half the speed),
- F4 switches framelimiter on/off.
If you used any of those keys you might as well switch the framelimiter off or changed it's limit by yourself, hence strange behaviour;p.
Reply
#4
(06-20-2013, 06:08 AM)DaTankAC Wrote: Are you playing from iso of the game made from imgburn? If you play from disc sometimes slowdowns will occur.

Playing from iso

(06-20-2013, 06:13 AM)miseru99 Wrote: ;p That's what I call wishfull thinking. Not only "i7" by itself isn't saying much, but also emulation is quite far from any kind of perfection and sayings like "ALL PS2 games" will not probably ever get at same sentence with "running on pcsx2".



Anyway for your problem, make note that:
- TAB is a key to turn on turbo(basically setting the framelimiter twice as high),
- shift+TAB turns slomo(by default setting it to half the speed),
- F4 switches framelimiter on/off.
If you used any of those keys you might as well switch the framelimiter off or changed it's limit by yourself, hence strange behaviour;p.

i7 isnt good enough?
i7-3610QM CPU @ 2.30 GHz

And Im pretty sure I have not been pressing those because I have been using a controller.
Reply
#5
You should still try pressing F4 to enable framelimiter couse without disabling it your fps couldn't get above 60fps(or 50 in pal). You might also just disabled it or messed it's settings in config>emulation settings>GS, if you messed it, restore defaults otherwise just make sure the checkbox to "disable framelimiter" is unchecked.

And about the slowdown, I think KH is pretty light game soo you shouldn't have problem even on mobile hardware, soo either you use too high upscalling(in gsdx config, you might turn the internal res down a bit) or you have windows power profile set as power saving which makes your laptop much slower than it is, change it to performance if that's the case(and don't try running pcsx2 on laptop battery;p).
Reply
#6
(06-20-2013, 06:53 AM)miseru99 Wrote: You should still try pressing F4 to enable framelimiter couse without disabling it your fps couldn't get above 60fps(or 50 in pal). You might also just disabled it or messed it's settings in config>emulation settings>GS, if you messed it, restore defaults otherwise just make sure the checkbox to "disable framelimiter" is unchecked.

And about the slowdown, I think KH is pretty light game soo you shouldn't have problem even on mobile hardware, soo either you use too high upscalling(in gsdx config, you might turn the internal res down a bit) or you have windows power profile set as power saving which makes your laptop much slower than it is, change it to performance if that's the case(and don't try running pcsx2 on laptop battery;p).

Ok I enabled framelimiter i do not know how to lower the internal res thoughSad I have it on native, i thought that was the lowest? And im plugged in on High Performance mode.
Reply
#7
Well GT 650 should handle much more(at least x3 of native probably;p), but you might not be using it in the first place.

Download svn build from here(if you aren't already using svn versionTongue, then just check gsdx config) and new GSdx should have a new option to choose adapter, choose your nvidia there and your problems will more likely be over.
Oh and a hint - if you use release 1.0.0 version now, you can just grab GSdx plugin dll from the archive to plugin folder in your current version and then select that new GSdx from plugin selector to avoid changing pcsx2 and messing your savestates.
Reply
#8
(06-20-2013, 07:27 AM)miseru99 Wrote: Well GT 650 should handle much more(at least x3 of native probably;p), but you might not be using it in the first place.

Download svn build from here(if you aren't already using svn versionTongue, then just check gsdx config) and new GSdx should have a new option to choose adapter, choose your nvidia there and your problems will more likely be over.
Oh and a hint - if you use release 1.0.0 version now, you can just grab GSdx plugin dll from the archive to plugin folder in your current version and then select that new GSdx from plugin selector to avoid changing pcsx2 and messing your savestates.

Which GSdx should i be using? And thank you so much for your help
Reply
#9
Either SSE4.1 or AVX(1 since now we also have AVX2, but it's for Hashwell only;p) one. Just get it from the most recent svn build and put the dll inside your current pcsx2\plugins directory then you'll be able to choose it in plugin selector.
Reply
#10
(06-20-2013, 08:03 PM)miseru99 Wrote: Either SSE4.1 or AVX(1 since now we also have AVX2, but it's for Hashwell only;p) one. Just get it from the most recent svn build and put the dll inside your current pcsx2\plugins directory then you'll be able to choose it in plugin selector.

ok thanks a lot! you were really helpful, gave you repWink
Reply




Users browsing this thread: 1 Guest(s)