Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frameskip flicker or system issue?
#1
Hello.

I'm running the PAL version of FF X on the following system:

Intel Pentium Dual Core T3400 2.16 GHz
NVidia GeForce 9600M GT
3 gb ram
Windows Vista Home Premium 32 bit
If it matters, it's a laptop.

I realize that that's about the minimum at which I can expect it to work at all, and my system generally manages to render 23-30 fps, which is enough to make it look fluid, but the game will be in slow motion. Which is where frame skip comes in. When I shut on frameskip, it flickers between complete frames and frames like this (screen 1) or this (screen 2). It seems to me that frameskip is showing me partially rendered frames. But this is only one of the available f*ckup modes. Other available modes include, but are not limited to: switching back and forth between previous frames, rendering the characters correctly but displaying a black silhouette behind them on the background where they were the previous frame and flickering between a black screen and a normal frame. Which mode is chosen seems to depend largely on what stage I'm in. All of those effects go away when I disable frameskip. In a different thread I read that it might be related to VU cycle stealing, but that has been constantly off and the setting of the other two VU settings in r-1888 don't matter.
This occured in both version 0.9.6, as well as r-1888.
My settings (in r-1888)
Graphics plugin: GDSX 2693 (MSVC 15.00, SSE3) 0.1.16
[Image: 6f9zs5.jpg]
CPU settings:
[Image: 14wgcwk.jpg]
Speed Hacks:
[Image: dnojyr.jpg]
Note that it makes no difference whether the Staus Flag Hack is enabled or not.

Also, i should mention that the issue has resolved itself once already: after waiting for a few seconds, the f*ckup stopped and the game ran perfectly fluid. Until I changed the screen, and since then it hasn't happened anymore.
Help would be appreciated.
Reply

Sponsored links

#2
Your PC should be able to handle FFX at almost full speed in general. This looks like a settings issue.
First don't use frameskip, it doesn't work very well in these PCSX2 versions.
You should set GSdx to DX10 hardware mode, cut back on the EEsync hack (i'd say set it to x1.5 or even default), disable vu cycle stealing totally and try again.
Also make sure Vsync is NOT enabled in your graphics card driver settings
[Image: newsig.jpg]
Reply
#3
(04-20-2010, 06:12 PM)Bositman Wrote: Your PC should be able to handle FFX at almost full speed in general. This looks like a settings issue.
First don't use frameskip, it doesn't work very well in these PCSX2 versions.
You should set GSdx to DX10 hardware mode, cut back on the EEsync hack (i'd say set it to x1.5 or even default), disable vu cycle stealing totally and try again.
Also make sure Vsync is NOT enabled in your graphics card driver settings

First, thank you for the quick answer!

I tried your settings, and most of that I had already tried before, when I played around with the settings. VSync is the first thing I shut off everywhere anyway, VU cycle stealing was off the entire time. Reducing EEsync hack helped slightly (~1fps difference), but DX10 actually makes it slower. My graphics card supports DX10, but it's usually better to stick to DX9. Another thing that helped immensely was disabling the two microVU settings under cpu (the ones marked as beta). That seems to do the trick - for now. I'd still like the option of frameskip, as I'm sure I'll have massive framerate breakdowns during bossfights/bestia animations.

But still, thank you for the help.
Reply
#4
Hmm DX10 slower? Do you have allow 8 bit textures off and the latest drivers for your graphics card? Up to date DirectX? (just having 10 is NOT up to date, use the direcx web updater for that) Maybe the mobile part of 9600 is pretty worse in DX10 performance than its' desktop counterpart...
A graphics card bottleneck will kill your speeds even with a working frame skipping technique I'm afraid..yeah mVU is slower than the old superVU but more compatible.
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)