Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frustrating loss of performance with Win7 x64
#1
I just installed Windows 7 x64 on my arcade machine. I've been testing all my emulators to make sure everything is still good. MAME saw a nice speed boost of about 22% with the lastest x64 version (the 32 bit version, still performns exactly like before), while Dolphin x64 remained unchanged from the old setup with Dolphin x32. However, PCSX2 has taken a significant hit on performance.
I've been using Soul Calibur III for the tests. With the old XP setup, I was getting 75-80% in game. With Win7 x64, I now get 55-60% on the same stage and the with the same fighters.

Does anyone know why this is?
Am I missing something?

I understand not gaining any performance, but it does not make sense to actually lose it.

Thanks.
Reply

Sponsored links

#2
Try to disable vsync within PCSX2, try to disable Aero (Windows 7 desktop), try DX9 at GSdx.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#3
shouldn't be using the pcsx2 vsync setting with GSDX, as Aero applies vsync automatically to pcsx2 going by memory (it did in 0.9.7).

the difference is likely your video drivers being out of date (or as shadow lady discovered, using the latest drivers on older gfx hardware).
Reply
#4
(05-27-2011, 03:59 PM)avih Wrote: Try to disable vsync within PCSX2, try to disable Aero (Windows 7 desktop), try DX9 at GSdx.

I've using DX9 on the plugin but also tried DX10 with no luck.
Regarding Aero, I will try that but why do you think that would help? When the game is on, Aero does not draw any CPU cycles unless you are moving screens around, etc.


(05-27-2011, 04:23 PM)Squall Leonhart Wrote: shouldn't be using the pcsx2 vsync setting with GSDX, as Aero applies vsync automatically to pcsx2 going by memory (it did in 0.9.7).
Hmm, interesting. I have vsync checked off. Do you mean that vsync might be working because of Aero, even if I have it checked off?

(05-27-2011, 04:23 PM)Squall Leonhart Wrote: the difference is likely your video drivers being out of date (or as shadow lady discovered, using the latest drivers on older gfx hardware).
I have the latest and greatest nVidia drivers. Do you recommend using trying older version?

Reply
#5
Quote:Hmm, interesting. I have vsync checked off. Do you mean that vsync might be working because of Aero, even if I have it checked off?

Yeah, the gsdx output renders in such a way that allows for fast switching between fullscreen and window, and one of the benefits of this is that Aero (or more accurately the DWM Compositor) prevents tearing.

what video card do you have?

anything older than the 200 series has been getting performance reductions with recent drivers of late.
Reply
#6
(05-27-2011, 04:31 PM)Squall Leonhart Wrote: Yeah, the gsdx output renders in such a way that allows for fast switching between fullscreen and window, and one of the benefits of this is that Aero (or more accurately the DWM Compositor) prevents tearing.
I see. So since I'm staying at the same video mode as my desktop when switching to full speed, I'm essentially doing vsync whereas I would not on Windows XP. If I understood this correctly, this could account for the full decrease in speed, since vsync is quite a performance hit on my system.
Will simply disabling Aero do away with the vsync, or do I have to change some driver global settings?

(05-27-2011, 04:31 PM)Squall Leonhart Wrote: what video card do you have?

anything older than the 200 series has been getting performance reductions with recent drivers of late.
I have a sad, overclocked GeForce 8500 GT. However, I recently posted about temporarily using a GTS 250 and seeing no benefit whatsoever on PCSX2, so I'm now very skeptical about the video card making any difference. Still, I'll try the experiment again and do another one with DX10, now that I have Win7.
Reply
#7
"I see. So since I'm staying at the same video mode as my desktop when switching to full speed, I'm essentially doing vsync whereas I would not on Windows XP. If I understood this correctly, this could account for the full decrease in speed, since vsync is quite a performance hit on my system.
Will simply disabling Aero do away with the vsync, or do I have to change some driver global settings?"

you'd need to disable DWM, but i've never seen pcsx2 affected by the doublebuffered frame dividing that vsync causes.
Reply
#8
(05-27-2011, 05:02 PM)Squall Leonhart Wrote: you'd need to disable DWM, but i've never seen pcsx2 affected by the doublebuffered frame dividing that vsync causes.

OK. I misunderstood your first reply. It sounds like the vsync from Aero is not a performance hit. Thanks for your patience.

I'm back to square one then, for figuring out what slowing me down in Windows 7 Sad
Reply
#9
Sure you're using the same emulator and GSdx builds?
Other than that, check your power saving options and try setting them to high performance.
Reply
#10
instead of power saving options check out if you can change something in your graphics adapter menue...its some kind of control panel...there you can choose whether the gpu or onboard will be used...was one of my first mistakes too not to look for that...hope it helped
Reply




Users browsing this thread: 1 Guest(s)