Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frustrating unsolved problem - Trying to Fraps Budokai Tenkaichi 3
Currently I'm playing DBZ Budokai Tenkaichi 3 (NTSC), which runs great normally. I run it at 60 FPS constantly even in heavy action-packed scenes. After watching some videos on YouTube I decided that I wanted to do some of my own videos as well, so I gave it a shot like I always do with Fraps. Now normally I have no problem at all running Fraps, but in this game in particular it completely kills the FPS. I get nothing more than 41-45 FPS.

The first attempt, the following configuration was used:

PCSX2 r1888
GSDX Settings:
Resolution: 1280x720
D3D Internal Res: 1680x1050

I figured at this point that the internal res might have been too high, so I tried lowering it to 1280x720, but it didn't have any positive results on the performance, and it still gave me 40 FPS.

A few days later I stumbled upon another video on YouTube of another PCSX2 user, who also had a video up using the same resolution and settings, except that he used an Internal Res of 1024x1024.(YouTube Link) So I gave it a shot with that, but once again it only gave me the same results as before.

At this point I decide to just try with "3x" and "2x" Native Res, this was recommended by another user on NGEmu Forums, but even that didn't help. I also tried messing with the CPU Affinity (Which was also suggested) to see if that might help as well, but again no luck with that.

I have tested out newer revisions too, but again I receive the same results. Even with the current r2695 release.

PC Specifications:
• Asus P6T Deluxe V2
• Intel Core i7 920 @ 3.50 GHz
• OCZ 6GB DDR3 1333
• Sapphire ATI Radeon HD5850 1024MB

Tried different versions of Fraps too. (3.0.1, 3.1.0, and 2.9.8)

In short: I should be capable of running Fraps with this game and maintaining 60 FPS, considering others have done it before me already, with an Internal Res of 1024x1024 even but yet I still can't do it. I hope someone is able to help out with this, or has any idea why it's just not working for me.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
ATI Radeon R9-280 3GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)

Sponsored links

Others could have recorded the game using the internal recording feature in PCSX2 (F12), this one regardless of FPS when being recorded plays the video back at full seed.

For Fraps I'd imagine you have to set the affinity of the Fraps process in task manager to others PCSX2 isn't using, for example force PCSX2 to use CPU1/2 and Fraps to 0/3-7
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
If you checked the video I linked you'd see he was using Fraps to record his video.
I already mentioned having changed the affinity for the CPU as well, that didn't improve the performance one bit sadly.

I really shouldn't have to rely on the built-in recorder when I have the same specs, (and better in some cases) as those other users who made 720p HD videos of this game. That's why I'm wondering if something else is causing the slowdowns.

Tried one new thing today: Native Res.

This brought the FPS to no higher than 48. So no significant boost again, even with Native Res.
I also forgot to mention that I also tried it with speed hacks, but you can already guess the results: No improvements.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
ATI Radeon R9-280 3GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Well pick your poison then, slow recording or internal recording (which apparently has nothing wrong with you). If I had to guess I'd say it's your fraps settings but I suppose it's better if you ask the person that made the video :P
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Yeah, I've been trying to get a hold of him, but no responses yet so far. Sad

There's not much to configure in Fraps either, you just select the FPS you want to record in, and choose the folder to save the recorded AVI to, and configure a hotkey for starting and stopping the record process, and that's pretty much it.

The only thing I can still think of is that overclocking to 4 GHz might help, but when I went from 3.2 to 3.6 I still didn't notice any significant boost, so I don't think this will matter much anymore either at this point. It's not something I can try right now due to a lack of proper cooling.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
ATI Radeon R9-280 3GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Try to use the Newest Fraps as possible....compared with older versions its lighter.i can do videos almost at fullspeed,but with older versions it chopped fps in half :X
I'm inactive on this, dedicating most of my time to osu!
when you record with FRAPS make sure you set 60 FPS in the recording options or else if you set it lower fraps will slow down PCSX2 to the specified FPS (i.e if you set 30 FPS in fraps the emu will run at 30 fps).

I gave up trying to record at full 60 fps using fraps because of my weak cpu. I decided to get smart and record at 29.97 fps (set fraps to record at and the limit in pcsx2 to 29.97 fps) and then use another program to double the playback rate to achieve 59.94 fps (normal speed for NTSC or 29.97 fps at normal speed).

I used Adobe Premiere and Soundbooth to speed up the video to normal speed but I had to separate the audio and export it to Soundbooth to speed it up because Premiere enjoyed making all the characters sound like the chipmunks even though the audio was being stretched and Soundbooth is able to speed up the audio and make it sound perfect and untouched.

Users browsing this thread: 1 Guest(s)