Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fullmetal Alchemist 2 fps problem plz help
#1
Hello

I am sorry if this has been posted somewhere else, i searched long and hard but failed to find this specific problem.

I have been using emulators for years, but PCSX2 is kinda new to me so forgive me if im alittle dense in that area.

I am currently using PCSX2 0.9.8 (r4600) to play the game "Fullmetal Alchemist 2 and the broken Angel" which is NTSC and ISO format.

I have 4X AMD Athlon dual cores processor
64-bit windows 7 pro
1x terabyte HD
4GB ram

All my video drivers are up to date and i am using all the standard plugins that came with the emulator.

The problem i am having is that the framerate seems to drop when viewing the animated cutscenes in the start of the game, and also during the game inbetween missions.

When i first start the emulation the framrate is sitting at 59-60 FPS, but when the game plays the intro cutscene the frame rate drops to 46 FPS, the video seems to be choppy, and the sound is really high pitched and kind of slow motion!

The gameplay seems to be running good (suprisingly), 56-60 FPS, but once again when i come to a cutscene the FPS drops automatically to 46FPS, its not a huge inconvinience but it does get anoying especialy when you have watched the FMA anime series...

Before all this was happening i had even slower frame rates than this and even the gameplay was slow, but i improved the performance by configuring the GSDX plugin and changing the Renderer from Direct3D9(Hardware) to Direct3D11(Hardware), this significantly improved gameplay and cutscene performance, but even after that the framerate still dropped at the cutscenes to 46FPS.

The gameplay FPS is fine, thats not the problem here.

I have also tried enabling speedhacks with EEcyclerate and VU cycle with mixed settings, and disabled clamping, i didnt notice any change.

Is there anyway to lock the FPS so that it CANT fall below 50FPS? or maybe i can change the frameskipping so that i can use (F4) everytime i get to the cutscenes? i really dont know what to do..

like i said before, i am a little dense so please dont get too technical with me, is there any settings or plugins i should change or get for this game? whats missing or what am i doing wrong?

Please help me, id be gladly appreciated!

Thanks
Reply

Sponsored links

#2
After 2 hours of playing around with the settings i finally got the cut scenes running at full speed 60 FPS!

I did this by changing Renderer in the graphics plugin to Direct3D11(software)

*sigh* the only problem with this is that now the GAMEPLAY framerate has gone from 60FPS to super slow motion...

Someone help me please..
Reply
#3
Press F9 while ingame to switch to hardware renderer or vice versa.
[Image: newsig.jpg]
Reply
#4
(05-24-2011, 11:39 AM)Bositman Wrote: Press F9 while ingame to switch to hardware renderer or vice versa.

Hey thanks Bositman!

This really helps! i didnt realise their was a shortcut key haha

For now i will just use (F9) everytime im at the cutscenes, i tried this just before, it kinda throws the audio out of sync, but ill get over it.. lol
Reply




Users browsing this thread: 1 Guest(s)