Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GOW- frameskip issue
have 0.9.6 and trying to play God of war 1 on my laptop

intel dual 2.2
3gb RAM
GeForce 9600mGT 512 dedicated
Windows 7

it works, its just running at 60% speed the whole time.
but i tried to set frameskip and no matter what i put it wouldnt do anything different...

its set on

"Frame Skip"
custom limit 60fps
skip when < 58fps
frames before skipping 0 (default) (have tried on 1,2,etc)
frames to skip 1

but have tried other arrangements, nothing changes it.


Sponsored links

Because frameskip works very badly with ps2 games. It's a problem on how they're designed.
You won't have much luck getting that game to run fullspeed, but you're free to try anyway Tongue2
so... you cant frameskip stuff at all...?
then whats the point of having a frameskip function haha

is there anything anyone can suggest to speed it up other than the various speed options in the cpu config box?

because other games run at full speed on my lappy no probs, so i would think its a GOW specific problem
You can frameskip and it actually helps if your GPU is the bottleneck for your game (while making it look choppy), if it is the CPU it will just have the choppy part.

Try the latest beta and turning on some speedhacks. Showing us your pcsx2 settings would help too Tongue
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
new beta gets instant 10% speed increase
runs at like 77%

when its going it says cpu is 6%...

what settings should i put up?

turned on in cpu config
and turned off frame skip (back to limit)

in speed hacks
(EE) 1.5x cycle rate
INTC sync hack
status flag hack

now runs at 98%.
dont know which did it, not gonna play with it haha


no wait. cinematic at the start now goes at 96% but gameplay is still hovering round 50%... wierd...
Unfortunately, unless you overclock your CPU a good deal, you probably won't get full speed in this game.

As stated before, if your video card was your bottle neck (the thing slowing you down) frameskip would help to some extent, but it's your CPU bottlenecking you here.
[Image: 2748844.png]
how is it the cpu dude?

its topping out at 7% when running...
cpu is dualcore 2.26, would think that would be plenty.

other games run at full speed fine, and i would have thought if it was the cpu bottlenecking it, it would be going in double digit percentages at least wouldnt it?

shadow lady said frameskipping would make it choppy, but it just seems to do nothing at all...
The "cpu" usage you see is only what GSdx needs for itself. It doesn't include pcsx2's needs.
A dualcore at just 2.26Ghz is certainly not enough, more like barely ok.
ohk did not know that haha
ok well thats probably the problem then...
that also explains why it dies when i have sound on even though it looked like there was heaps of spare processing

ta for the help

Users browsing this thread: 1 Guest(s)