Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GS Plugin won't load...?!
#1
Hello,

I see many posts from people who are experiencing the same error message. I'm really perplexed though... Here are my system specs-

Windows 7 Home Premium 64
Intel Core 2 Duo E7200 2.53GHz
2 GB Ram
Geforce 8800 GT Graphics adapter

I have the Intel chip which supports SSE4.1 and SSSE3 instruction sets. My graphics card is DX10 compatible, and I am running DX10, but no matter which of the 3 gsdx msvc 15 .0.1.16 plugins I use, I always get the same error: GS Plugin failed to open. See log dump below:

PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition (build 7600), 64-bit
Physical RAM = 2047 MB
CPU name = Intel® Core™2 Duo CPU E7200 @ 2.53GHz
Vendor/Model = GenuineIntel (stepping 06)
CPU speed = 2.532 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0008e39d
x86EFlags = 20000000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Reserving memory for recompilers...

Loading plugins...
Binding GS : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\gsdx-sse4-r4600.dll
(GameDB) Database Not Found! [C:\Program Files (x86)\pcsx2-r1888\GameIndex.dbf]
Windows 6.1.7600
NVIDIA GeForce 8800 GT (8.17.12.8562)
Binding PAD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\cdvdiso-r4600.dll
Binding USB : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

[wx] can't commit changes to file 'C:\Users\Ronin Sanji\Documents\PCSX2\inis\PCSX2_ui.ini' (error 5: access is denied.)
[wx] Failed to update user configuration file.
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7600
NVIDIA GeForce 8800 GT (8.17.12.8562)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
[wx] can't commit changes to file 'C:\Users\Ronin Sanji\Documents\PCSX2\inis\PCSX2_ui.ini' (error 5: access is denied.)
[wx] Failed to update user configuration file.
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: H:\Tenchu Wrath of Heaven.nrg
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1921046 sectors)
Opening USB
Opening FW
Opening DEV9
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
(pxActionEvent) GS plugin failed to open!(thread:MTGS)(thread:EE Core)

My system isn't the newest, but I just can't understand why I am getting this error. Please assist and thank you in advance.
Reply

Sponsored links

#2
Error code 5 indicates that you do not have sufficient privilege to access the file. Is your current account administrator?

When you're sure you have administrative priviledge, update your DirectX runtime library. If still does not work, so your CPU does not support your selected intruction set (unlikely to happen, but does happen when you runs PCSX2 inside a virtual machine).
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#3
Update your DirectX Redistributables and download the Binary Version of PCSX2 0.9.8. Also, right click pcsx2 and sleect Run as Admionistrator to get past the issue. Hope that helps. Smile
[Image: recodersignature2.png]
Reply
#4
Thank You very much for your recommendations. I ran as administrator, which made the
"[wx] can't commit changes to file 'C:\Users\Ronin Sanji\Documents\PCSX2\inis\PCSX2_ui.ini' (error 5: access is denied.)
[wx] Failed to update user configuration file." go away. Thank you for that, but the GS plugin still fails to initialize. I tried to update my Direct X runtime libraries, but I got:
"Direct X setup has determined that a newer or equivalent version of direct x has been installed already. No installation is necessary."

My CPU should support any of the three instruction sets, and none of the three will initialize. I'm not running the application in a virtual machine...I'm so confused...

I downloaded the binary version, but same problem persists...
Thank you all for your support! Does anyone have any other ideas?
Reply
#5
Hm that's strange. Try this: Use the binary version of PCSX2 and extract it in a folder like C:/PCSX2. Then create an ISO image of the game using imgburn since that .nrg image you have might be causing problems.
Then to run it: Dismount the ISO from any program like daemon tools etc. Then CDVD->Choose ISO, then ISO selector->Browse, find your ISO and System->Boot CD/DVD (fast)
[Image: newsig.jpg]
Reply
#6
recoder Wrote:Update your DirectX Redistributables and download the Binary Version of PCSX2 0.9.8. Also, right click pcsx2 and sleect Run as Admionistrator to get past the issue. Hope that helps.

Probably your are using Web or Full Installer. Try the Binary Version or create a blank portable.ini fine in your pcsx2 folder and then re-configure your PCSX2.
[Image: recodersignature2.png]
Reply
#7
Hello Everybody,

Sorry for the radio silence over the last week, but I get busy with work, etc. and don't have much time to troubleshoot except the weekend. I found the answer. It is a strange and frustrating problem I'm sure others will also experience, but has nothing to do with the emulator itself. Just in case anybody else runs into this issue, here's fixed it for me:

I ran DXdiag for 64 bit applications and everything looked fine, but when I checked dxdiag for 32 bit applications, for some inexplicable, bizzare reason, (it must be disabled by default in DX10 64-bit, but why?) direct 3d was disabled. Since I'm using windows 7, there is no button to simply enable direct 3d. I searched several forums and found the answer was to edit this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Direct3D\Drivers\SoftwareOnly

This key had a value of 1 and that was preventing PCSX2 from running direct 3d applications in 32 bit mode. I just changed it to 0. Now the emulator runs fine...

Hopefully someone else on the internet who is about ready to give up on Playstation 2 emulation will read this post, and hopefully it can resolve some of the issues people are having with the software.
Reply
#8
May this thread help to remember once again that no game which can be modded or has plugins should be installed on C:\Program Files (x86) on Vista or 7.

The best policy is NOT installing any games in such folder or any other specially Windows Protected folder, like the Desktop or (My) Documents folder, this last should be avoided even on XP.

Remember, this is just for "running" the application from inside those folders, no problems having the control files there, like the ini and save files...
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)