Thread Rating:
  • 2 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GS plugin failed to open/initialize problem
#1
When I try to Run CD/DVD, it states "Please update DirectX! Would you like to go to the download page?". I click "No" since I am running on Windows Vista and I have a DirectX 10 compatible video card. After that, a window pops up stating "An unhandled or unrecoverable exception occured, with the message: The GS plugin failed to open/initialize. Pcsx2 will now close. More details may be available via the emuLog.txt file."

I have tried the SSE2 and SSE3 versions of the GSdx Graphics option and Direct3D 10 and 9. Also, I've tried P.E.Op.S CDDVD and Gigahertz CDDVD Plugin 0.7.0. for the cddvdrom option. I've also tried both the Windows Installation and Binary versions and of course there is no difference. I have not been able to find a solution to this problem which is interesting since I didn't have these problems with the 0.9.5 version.

p.s. I think the problem could be that the emulator isn't detecting my DirectX.

Much help appreciated!


Attached Files Thumbnail(s)
   

.txt   emuLog.txt (Size: 843 bytes / Downloads: 1.564)

Sponsored links

#2
(03-08-2009, 11:04 PM)zuN Wrote: it states "Please update DirectX! Would you like to go to the download page?". I click "No"
uhh you clicked "no", obviously it won't work without updating directx (even if you think that you have the latest one).
so go do that then come back if anything else comes up. Closedeyes

(i beat the moderators to this Laugh)
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
#3
I don't use vista but I don't think having in means you don't need to update your DirectX.GSdx requires to have d3dx9_40.dll for DX9 and d3dx10_40.dll for DX10 in your C:\WINDOWS\system32 folder(they are placed there when you install the newest DX)
#4
(03-08-2009, 11:11 PM)vsub Wrote: I don't use vista but I don't think having in means you don't need to update your DirectX.GSdx requires to have d3dx9_40.dll for DX9 and d3dx10_40.dll for DX10 in your C:\WINDOWS\system32 folder(they are placed there when you install the newest DX)
yes, that's correct right there. Smile
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
#5
Ah yea that fixed it. Thanks!

btw, i can't believe how smooth this version of pcsx2 is Laugh

edit: Offtopic: 1 question, when i click ESC to save a state/choose a state to save, it closes my game and I have to restart it afterwards. Any way to stop this from happening?
#6
just go to "run->execute" to go back to the game, or better just click F1 to save state, F2 to go to the next savestate (shift+F2 to go to previous), and F3 to load the current savestate. Smile
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
#7
thanks Laugh
#8
(03-08-2009, 11:12 PM)LuisR14 Wrote:
(03-08-2009, 11:11 PM)vsub Wrote: I don't use vista but I don't think having in means you don't need to update your DirectX.GSdx requires to have d3dx9_40.dll for DX9 and d3dx10_40.dll for DX10 in your C:\WINDOWS\system32 folder(they are placed there when you install the newest DX)
yes, that's correct right there. Smile

yes im having the same prob shes having i have the cinfig in everything set right but when i clikc run cd/dvd the following message pops up about the gs plugin in things what do i need 2 do to get this ps2 emulator runing plz i need 2 play naruto =]
#9
didn't you read the second post? Mellow
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
#10
(03-16-2009, 11:22 PM)LuisR14 Wrote: didn't you read the second post? Mellow
THIS IS WHAT IM GETTING PCSX2 0.9.6 - compiled on Feb 27 2009
Savestate version: 8b400004
x86Init:
CPU vendor name = GenuineIntel
FamilyID = 7
x86Family = Intel® Pentium® 4 CPU 1300MHz
CPU speed = 1.295 Ghz
Cores = 1 physical [1 logical]
x86PType = Standard OEM
x86Flags = 3febfbff 00000000
x86EFlags = 00000000

Features:
Detected MMX
Detected SSE
Detected SSE2
Not Detected SSE3
Not Detected SSSE3
Not Detected SSE4.1

Hotkeys:
F1 - save state
(Shift +) F2 - cycle states
F3 - load state
Resetting...
Ready
Bios Version 1.60



**************
rom2 NOT FOUND
**************






**************
erom NOT FOUND
**************



Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
MTGS > Thread Started, Opening GS Plugin...
MTGS > GSopen Finished, return code: 0xffffffff



WHAT DO I NEED?




Users browsing this thread: 1 Guest(s)