Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDX: Hardware mode [Bug Report] Allow 8-bit Texture
#1
This bug report is dedicated to GSDX. The Problem is that Enabling Allow 8-bit Texture has some bugs in the Graphics. Avih said that Enabling Allow 8-bit Texture should not modify the output. It may/may not bring Speedups in the Game.

Feel Free to move this Bug Report Tongue2

# Configuration (used throughout)
#CPU : Default, and no other changes
#Plugin : GSDX SSE4.1
   Renderer : DirectX 10
   Windows Resolution : Tested with 1024x768, 1600x900
   Internal Resolution   : The Images are of 3x Native but Tested and confirmed to be bugged at Native, 3x Native and Custom Resolutions of 1400x1400, 1024x1024 etc.
   Texture Filtering : Half State
   Allow 8-bit Texture : see below...
   Hacks : Disabled

# PCSX2 version: PCSX2 SVN r5336 (which was available for download on the buildbot)
# CPU options: Default, No Speedhacks or Gamefixes or Frameskip etc.
# Plugins used: GSDX r5336 0.1.16 SSE41
# Description: See the Comparison Images below.
# Game : Dragon Ball Z Budokai Tenkaichi 3 NTSC
#Extra Info : You need to zoom it a bit to see the glitch better. The Windows Photo Viewer is just fine enough to do it.

With Allow 8-bit Textures ON



[Image: capturedbz18bit.jpg]

[Image: capturedbz8bitedit.jpg]

With Allow 8-bit Textures OFF



[Image: capturedbz18bitoff.jpg]

[Image: capturedbz8bitoff.jpg]



# PCSX2 version: Official PCSX2 0.9.8
# CPU options: Default, No Speedhacks or Gamefixes or Frameskip etc.
# Plugins used: GSDX r4600 SSE41
# Description: See the Comparison Images below.

With Allow 8-bit Textures ON



[Image: attachment.php?aid=30830]

[Image: attachment.php?aid=30831]

[Image: attachment.php?aid=30832]




With Allow 8-bit Textures OFF



With Allow 8-bit Texture OFF, it is same as the images Above
[Image: recodersignature2.png]
Reply

Sponsored links

#2
Well never noticed it before had it pointed, but can confirm that problem;P.

It doesn't happens at all in DX9 through, and I guess allow 8-bit textures works exactly same in dx9 and dx10+(with just name change of the format returned, but that's same thing still), soo maybe it's not a problem of "allow 8-bit textures" at all, but rather something of DX10+ mode doing(or not) with those textures;c.

edit: about it, r4600 looks same as r4922 with that problem for me(and surely no white graphics here, but I used old gsdx over new pcsx2;P), r5133 and above look differently soo something affects it in between, not sure which exactly.
Reply
#3
some kind of alpha corruption on square tiles, hmm
Reply
#4
With my setup, enabling "Allow 8-bit textures" drops the fps by 6-7 frames (ASUS HD7870 - DX11)
Reply
#5
(07-17-2012, 11:07 AM)GeoMan Wrote: With my setup, enabling "Allow 8-bit textures" drops the fps by 6-7 frames (ASUS HD7870 - DX11)

...which is totally irrelevant with this bug report.
[Image: newsig.jpg]
Reply
#6
I checked some of the builds I had and something affects that bug(in negative way;P ~ makes it more visible) between r5036-5065, from checking older revs it was present from the beginning of allow 8-bit textures option(always only in dx10+).

Edit: seems that more games are affected if not all;P, just an example from Odin's Sphere, check the bottom of "Armageddon" sign:
DX10/11 + allow 8 bit textures:
   

DX10/11 without 8 bit textures:
   

DX9 is completely unaffected by the option.

Also I guess r5045 is what making it slightly worser(through that could be subjective observation, let's just say the bug is slightly different after that revision in some cases;]).
Reply
#7
Maybe I didn't understand how that option works...give more speed(not always)in exchange of graphic bugs.
If this is not how it's supposed to work,then those problems exist from long time ago.
Reply
#8
This bug has always been there for me. I just assumed it was because I'm using ATi.
Reply
#9
miseru99: Are you also using an ATI card? I don't get your issues in Odin Sphere at all on my Nvidia.
Reply
#10
Oh yeah, so AMD fail again;] hd5670 here on that bug. ;3
Reply




Users browsing this thread: 1 Guest(s)