Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDX: Hardware mode [Bug Report] Ape Escape 2 [NTSC-U]
#1
PCSX2 version: 1.4.0 / 1.5.0-20161101175446 (git)
CPU options: EE/IOP defaults, VUs defaults
Speedhacks: Tested with and without SH, no changes.
Plugins: GSdx 1.1.0 / SPU2 2.0.0
HW hacks: Tried activating every single one with no results. Didn't fiddle with skipdraw.
Game patches: None, tried some, didn't help


Specs:
OS: Windows 10 Familial editiion
CPU: Intel i5 4670k x4 3.40GHz
GPU: GTX 760 GIGABYTE OC
RAM: 16GB DDR3


Description: Going underwater in Ape Escape 2 while in hardware mode causes massive drops in FPS ans graphical glitches (water overlay doesn't appear, shadows are glitched).


No problems in software mode, removing MSAA or dropping the resolution lessens the stutters to a point where MSAAx0 in native res runs at full speed on my config but it still has graphical glitches. Happens in DX11/DX9/OGL (DX9/11 appear to stutter massively after 10s near water without even entering it). Thought it came from the mipmapping in hardware mode hack from latest builds but it still happens in 1.4.0.

Video:




Hope I followed the forum instructions well enough, if it lacks details just ask and I'll add them.
Reply

Sponsored links

#2
tried latest git ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Yes, using latest git, v1.5.0-dev-1525-g437afbb. I downloaded it yesterday to test the new hardware mode mipmapping hack. So far it works great but this bug kinda ruins the experience, having to press f9 everytime I need to swim in the game :\
Reply
#4
Does this issue happen in all hardware renderers (D3D9/D3D11/OpenGL)?

Providing a GS Dump of the issue might be useful.
Reply
#5
As stated in the first post, it does that in every mode, dx11,dx9 and ogl are hit. Tho only opengl doesnt stutter when outside the water, dx 9 and 11 end up stuttering by themselves when near water.

Ill provide a dump when i can, not home right now.
Reply
#6
Can you try unticking large framebuffer and enabling hw hacks then enabling the Fast Invalidation hack, see if that helps.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(11-04-2016, 12:00 PM)refraction Wrote: Can you try unticking large framebuffer and enabling hw hacks then enabling the Fast Invalidation hack, see if that helps.
Make sure the renderer is set to OGL.
Reply
#8
But which mipmap did you enable ? Level 1 or 2 ? Level 2 requires OGL (and likely slow and broken).
Reply
#9
(11-04-2016, 01:28 PM)gregory Wrote: But which mipmap did you enable ? Level 1 or 2 ? Level 2 requires OGL (and likely slow and broken).
But if the issue occurs in v1.4.0, that doesn't really matter.
Reply
#10
Oh. Broken mipmap can kill the perf. If the game set an invalid address, it could point to an old frame buffer. Data will be converted. Dx might do it on the CPU whereas OpenGL can do it on the GPU. Try to play with the CRC level. Note: the game can also uses some pseudo 8 bits frame buffer on purpose.
Reply




Users browsing this thread: 1 Guest(s)