Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSDX: Hardware mode [Bug Report] Black [PAL] - Graphical Bug(s)
#1
In 1.4.0 using Direct3D11, Direct3D9 and OpenGL (in Hardware Mode), Black's gun reload blur is missing. Also, the gun's textures seem to flicker or bug a bit when reloading too.

Bad (Hardware Mode):

[Image: 56Ud4aW.jpg]

Proper (via Software Mode):

[Image: dP45gfn.jpg]

I think Software mode reproduces the gun's details more clearly (despite lower resolution). The colour scheme seems different too. Also, the hand is missing only because the pictures were taken at different times, the hand has not grown legs and walked away.  Tongue

Just for reference, here are my video settings (For hardware mode):

[Image: rMCFcDO.png]

Also, yes, I know Software mode is more accurate, and Hardware mode is faster because it's less accurate, but I hope this can be resolved in some way. I would say there is a workaround in hardware hacks. I'll give it a go and try some hardware hacks and report back. And before you ask, no, no EE/VU hacks were used.

[Edit] Hardware Hacks Attempted (without success):
* Wild Arms Offset
* Half-pixel Offset
* Skipdraw: 1
* Skipdraw: 2
* Alpha
* Align Sprite
* Alpha Stencil
Reply

Sponsored links

#2
Before going any further could you give us your computer specs? CPU, GPU, RAM, etc.
Does this affect all weapons?
Reply
#3
Worth to try: opengl + less crc hack + new accurate options
Reply
#4
This game in general seems to use alot of post-processing. What happens if you try Hardware Mode at Native Res?

If you're into using OpenGL, try using Hardware Depth. I found in GT4 that it upscales DoF/blur effects correctly. Maybe it could fix your problem?
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#5
Alright guys, thanks for the help.

First off, I'm using an i5-4690 (non-K), GTX 960 2GB and 12GB of RAM.
Secondly, yes, this affects all weapons I have tried.

Now for the test results. Using OpenGL, Direct3D9 and Direct3D11 at native resolution and in Hardware Mode yield no improvement. I have also tried enabling Hardware Depth in OpenGL, as CK1 suggested, but unfortunately this didn't affect it.

I'm about to try OpenGL + less CRC Hack + New Accurate options, I'll edit this post with results.

Edit: Tried OpenGL + Partial CRC + Ultra Accurate blending, but to no avail. Any more suggestions, hit me.
Reply
#6
Guys, I found a fix!

Fix: Use OpenGL and CRC Hacks to Minimum or Off. This gives a near-perfect blur effect.
It looks brilliant, along with Hardware Mode's obvious graphical enhancements. However, I would say the motion blur is missing the "warm" colours look that Software Mode properly reproduces. That is probably either in need of me trying more suggested workarounds or a fix for this. Either way, I'm happy for now, but I'd like the colour "bug" (I suppose) to be fixed

Minimum CRC [OpenGL]:

[Image: TX2o3bu.jpg]


However, using Direct3D11 makes the game horridly slow (sagging along at 1-5FPS), and will look like so:

[Image: A3jlFvg.png]
Reply
#7
Try using a higher level of Blending unit accuracy and check whether the color bug still persists.
Reply
#8
Some people report that BA helps with this game (washed color)
Reply
#9
Sorry to bump, but I haven't been here in a while and I'm reporting back on higher BA.

In short: No, higher BA didn't produce any [much] better results, unfortunately. Maybe I'm too tired to notice, but I don't see any real improvement.

[Image: ALqNuXI.png]

The image colours don't look as nice as in software mode, and this is in OGL with Blending Accuracy on Ultra.

Thanks for the help though, guys.
Reply




Users browsing this thread: 1 Guest(s)